Replicating Linaro Images to more memory cards

Sudhangathan B S sudhangathan at gmail.com
Fri Feb 17 07:26:50 UTC 2012


I'm using Gumstix Overo-Fire.
I need to replicate my systems to deploy and test my setup. Right now I
have one uSD memory card which is working fine, but when I copy the whole
card using either the `tar cvpf` or dd commands, the image doesn't work on
any other memory card. Below is the console message when it hangs. I have
tried many memory cards.

Looks like Linaro images store the memory card ID and search for them
during the boot time, which will obviously fail on a different card.

Is there any way I can make my Linaro Image memory card independent.... so
that my replication becomes easy..??


These are the last lines from the console messages during the boot, with
the replicated memory card.

[    6.605651] usbcore: registered new interface driver usbhid

[    6.617279] usbhid: USB HID core driver

Gave up waiting for root device.  Common problems:

 - Boot args (cat /proc/cmdline)

   - Check rootdelay= (did the system wait long enough?)

   - Check root= (did the system wait for the right device?)

 - Missing modules (cat /proc/modules; ls /dev)

ALERT!  /dev/disk/by-uuid/17fb7403-3757-4533-b783-7be5436d9882 does not
exist. !


---------------------------------
Sudhangathan BS
Ph:(+91) 9731-905-205
---------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linaro.org/pipermail/linaro-dev/attachments/20120217/f75f0284/attachment.html>


More information about the linaro-dev mailing list