[PATCH 08/11] ramoops: Move to fs/pstore/ram.c
anton.vorontsov at linaro.org
Wed May 16 00:19:08 UTC 2012
On Mon, May 14, 2012 at 02:34:18PM -0700, Kees Cook wrote:
> On Fri, May 11, 2012 at 5:18 PM, Anton Vorontsov
> <anton.vorontsov at linaro.org> wrote:
> > Since ramoops was converted to pstore, it has nothing to do with character
> > devices nowadays. Instead, today it is just a RAM backend for pstore.
> > The patch just moves things around. There are a few changes were needed
> > because of the move:
> > 1. Kconfig and Makefiles fixups, of course.
> > 2. In pstore/ram.c we have to play a bit with MODULE_PARAM_PREFIX, this
> > is needed to keep user experience the same as with ramoops driver
> > (i.e. so that ramoops.foo kernel command line arguments would still
> > work).
> > Signed-off-by: Anton Vorontsov <anton.vorontsov at linaro.org>
> This consolidation seems good. I might prefer the move separated from
> the changes, just to make review easier, but I have no idea what
> that'll do to a bisect. :P
Yep, exactly, the point of making the changes together with the
move was to keep things bisectable.
> > --- /dev/null
> > +++ b/fs/pstore/ram.c
> "ram.ko" seems like an awfully generic modbule name. Should this be
> called pstore_ram.* instead, like was done for the header file?
Oh, right you are. Actually, if I'd change the module name via
Makefile (i.e. ramoops-objs = ram.o), we can get rid of
MODULE_PARAM_PREFIX hack. So, I'd just name the module ramoops.ko
name, but keep the ram.c source file name.
Thanks for the hint.
> And unless anyone objects, I have no problem letting the built-in name
> change too.
> > --- /dev/null
> > +++ b/include/linux/pstore_ram.h
> > @@ -0,0 +1,17 @@
> > +#ifndef __RAMOOPS_H
> > +#define __RAMOOPS_H
> This define should probably change just to avoid confusion.
Email: cbouatmailru at gmail.com
More information about the linaro-kernel