Running pre-built linaro toolchain failed on Ubuntu 11.04, 64bit server

Lv Terry-R65388 r65388 at freescale.com
Wed Jan 11 05:49:07 UTC 2012


Hi Michael,

	Here it is:

r65388 at shlinux3:~/toolchain_ltib/gcc-linaro-4.6.3-glibc-2.13-singlelib-2011.12/arm-fsl-linux-gnueabi/bin$ ldd arm-linux-gnueabi-gcc
        linux-gate.so.1 =>  (0xf770f000)
        libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7602000)
        libm.so.6 => /lib32/libm.so.6 (0xf75d8000)
        libpthread.so.0 => /lib32/libpthread.so.0 (0xf75bc000)
        libdl.so.2 => /lib32/libdl.so.2 (0xf75b7000)
        libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7599000)
        libc.so.6 => /lib32/libc.so.6 (0xf741f000)
        /lib/ld-lsb.so.3 => /lib/ld-linux.so.2 (0xf7710000)

	Thanks~~

Yours
Terry

-----Original Message-----
From: Michael Hope [mailto:michael.hope at linaro.org] 
Sent: 2012年1月11日 13:37
To: Lv Terry-R65388
Cc: linaro-toolchain at lists.linaro.org
Subject: Re: Running pre-built linaro toolchain failed on Ubuntu 11.04, 64bit server

2012/1/11 Lv Terry-R65388 <r65388 at freescale.com>:
> Hi Michael,
>
>        Actually, I've already have ia32-libs and ia32-libs-multiarch installed.
>
> r65388 at shlinux3:~/toolchain_ltib/ltib$ sudo apt-get install ia32-libs 
> Reading package lists... Done Building dependency tree Reading state 
> information... Done ia32-libs is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 67 not upgraded.
> r65388 at shlinux3:~/toolchain_ltib/ltib$ sudo apt-get install 
> ia32-libs-multiarch                                                               
> Reading package lists... Done Building dependency tree Reading state 
> information... Done
> ia32-libs-multiarch:i386 is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 67 not upgraded.
> r65388 at shlinux3:~/toolchain_ltib/ltib$ 
> ~/toolchain_ltib/gcc-linaro-4.6.3-glibc-2.13-singlelib-2011.12/arm-fsl
> -linux-gnueabi/bin/arm-linux-gnueabi-gcc
> -bash: 
> /home/r65388/toolchain_ltib/gcc-linaro-4.6.3-glibc-2.13-singlelib-2011
> .12/arm-fsl-linux-gnueabi/bin/arm-linux-gnueabi-gcc: No such file or 
> directory
>
>        Do you have more suggestions?
>
>        Is it linking to a wrong library?

Hmm, interesting.  What does ldd show?  Here's what I see on my Lucid box:

michaelh at crucis:~/linaro/binary/check/gcc-linaro-arm-linux-gnueabi-2011.12-20111219+bzr2309~linux/bin$
ldd arm-linux-gnueabi-gcc
        linux-gate.so.1 =>  (0xf77c5000)
        libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf76a9000)
        libm.so.6 => /lib32/libm.so.6 (0xf7683000)
        libpthread.so.0 => /lib32/libpthread.so.0 (0xf7669000)
        libdl.so.2 => /lib32/libdl.so.2 (0xf7665000)
        libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7646000)
        libc.so.6 => /lib32/libc.so.6 (0xf74ec000)
        /lib/ld-lsb.so.3 => /lib/ld-linux.so.2 (0xf77c6000)

-- Michael



More information about the linaro-toolchain mailing list