[Linaro-validation] master boot image and uboot commands

Andy Doan andy.doan at linaro.org
Tue Apr 10 17:00:13 UTC 2012


On 04/10/2012 11:55 AM, Andy Doan wrote:
> On 04/10/2012 11:52 AM, Zygmunt Krynicki wrote:
>> W dniu 10.04.2012 18:50, Andy Doan pisze:
>>> I've been setting up a local LAVA lab on my home network. I've used the
>>> lava-deployment-tool and lava-master-image-scripts to get my Beagle
>>> hooked up.
>>>
>>> I'm really close to having everything work. However, when I submit a job
>>> I hit a problem with the soft-reboot logic not being able to instruct
>>> u-boot to use the test image.
>>>
>>> I'm flashing a 12.01 pre-built nano image, but I don't think that
>>> matters. I think the real issue might be something with a newer uboot
>>> being used by the linaro-master-image-script and the device.conf for
>>> beagle not having the right stuff.
>>
>> That master has not been validated. It fact I'm surprised you managed to
>> boot it at all because of thumb kernel bugs that generally crash the
>> system shortly after booting. Out of curiosity, which beagle did you use
>> C4 or XM?
>
> XM
>
>> We should revert the beagle master hwpack to something older that works
>> well with real hardware and our dispatcher code.
>
> So for now, does anyone have a master image I can just download for
> beagle, or do I really need to create this by hand still?

Sorry - sent before I meant to. I meant to ask if there was beagle 
hwpack I should use instead? It looks like I can just update the 
boards.d/beagle.conf file in the tool to use a better hwpack.




More information about the linaro-validation mailing list