On Thu, Jul 19, 2012 at 5:04 AM, Pawel Moll <pawel.moll@arm.com> wrote:
On Wed, 2012-07-18 at 17:01 -0300, Christian Robottom Reis wrote:
> On Thu, Jul 12, 2012 at 02:54:15PM -0500, Paul Larson wrote:
> > I've been looking a bit at how to get this running under DS-5, but I
> > haven't found much documentation.  Best thing I've found so far has been
> > http://www.youtube.com/watch?v=aDStdtopy_g
> > I tried going through this, and even found caiman on my box at
> > /usr/local/DS-5/bin/caiman
> >
> > However, when I try to replicate what they did here, I get a trace ok, but
> > no power data in my graph.  You may want to give it a try though, maybe it
> > will work for you.
> Zach, Alexander and I spent some time trying to get it to work in Hong
> Kong and got to exactly the same results as you are describing.

If I was to guess I'd say you hit a device detection bug in caiman. In
99% cases it can be easily worked around (providing you use 5.10
release) by enforcing the device node name in the cayman configuration

So, click "Capture options" button (the cogwheel like icon, the middle
one of three) and make sure that the "Energy Capture" input contains

        <DS-5-path>/bin/caiman -d /dev/ttyACM0

I have 5.10 (build 1389)
I tried putting this in the energy capture field:
/usr/local/DS-5/bin/caiman -d /dev/ttyACM0
(I also see /usr/local/DS-5/sw/energy_probe/caiman, but the one in /usr/local/DS-5/bin seems to be the script that sets things up for it and calls the latter)

I tried this, but still not getting anything.  The only things I see in the timeline after running the capture are:
Linux Scheduler
Disk IO

Also, fwiw, I tried running caiman from the command line, even with specifying -d /dev/ttyACM0 and I get no output.  Not sure if I'm supposed to get anything though.  All it does is create an empty file called "0000000000"
Paul Larson