On 15 September 2014 12:45, Morten Rasmussen morten.rasmussen@arm.com wrote:
On Thu, Sep 11, 2014 at 03:04:44PM +0100, Peter Zijlstra wrote:
On Thu, Sep 11, 2014 at 03:07:52PM +0200, Vincent Guittot wrote:
Also I'm not entirely sure I like the usage, utilization names/metrics. I would suggest to reverse them. Call the pure running number 'utilization' and this scaled with capacity 'usage' or so.
ok. i can invert 'usage' and 'utilization', which will give
s/get_cpu_utilization/get_cpu_usage/ s/sgs->group_utilization/sgs->group_usage/
The confusion will have new dimensions added when we introduce scale-invariance too. Then the running number is already scaled by the current P-state compute capacity. But I don't have any better suggestions.
s/cfs.usage_load_avg/cfs.utilization_load_avg/
I don't like using "load" for unweighted metrics. I associate load with something that may be weighted by priority like load_avg_contrib, and utilization with pure cpu utilization as in how many cycles is spend on a particular task. I called it "usage_util_avg" in my own patches, but "util_avg" might be better if we agree that utilization == usage.
ok. so i don't have the same definition than you. IMHO, load should be used for figures that have used the average of the geometric series used in the per entity load tracking more than the fact that we weight the figures with priority
s/se->avg.usage_avg_contrib/se->avg.utilization_avg_contrib
util_avg_contrib maybe to keep it shorter.
s/__update_task_entity_usage/__update_task_entity_utilization s/__update_entity_usage_avg_contrib/__update_entity_utilization_avg_contrib
Maybe use "util" here as well?
I agree that utilization can be a bit too long but util sounds a bit too short ans we loose the utilization meaning. so we could use activity instead of utilization
Nevertheless, the most important is that we find a common definition convention
Would the following proposal be ok ?
s/get_cpu_utilization/get_cpu_usage/ s/sgs->group_utilization/sgs->group_usage/ s/cfs.usage_load_avg/cfs.activity_load_avg/ s/se->avg.usage_avg_contrib/se->avg.activity_avg_contrib s/__update_task_entity_usage/__update_task_entity_activity s/__update_entity_usage_avg_contrib/__update_entity_activity_avg_contrib
Vincent
Morten