On Thu, Nov 21, 2019 at 12:05:33PM +0100, Borislav Petkov wrote:
On Thu, Nov 21, 2019 at 12:41:45PM +0200, Jarkko Sakkinen wrote:
On Thu, Nov 21, 2019 at 12:39:25PM +0200, Jarkko Sakkinen wrote:
+void init_feature_control_msr(struct cpuinfo_x86 *c)
I'd also use here shorter init_feat_ctl_msr(). It has one call site but shorter name is more convenient when playing with tracing tools.
Yeah, and since we're shortening all to feat_ctl, let's do:
mv arch/x86/kernel/cpu/feature_control.c arch/x86/kernel/cpu/feat_ctl.c
Any objection to keeping the MSR name as MSR_IA32_FEATURE_CONTOL? I'd like to have some anchor back to the name used in the SDM.
Any opinions/thoughts on the name of the Kconfig? Currently it's X86_FEATURE_CONTROL_MSR, which gets a bit long with CONFIG_ on the front. I also overlooked that we have MSR_MISC_FEATURE_CONTROL, so having IA32 in the Kconfig would probably be a good idea. X86_IA32 is rather redundant, so maybe IA32_FEAT_CTL or IA32_FEATURE_CONTROL?