Changing default root filesystem to ext4

Tixy tixy at
Thu Aug 18 12:18:29 UTC 2011

On Wed, 2011-08-17 at 11:48 +0100, James Tunnicliffe wrote:
> On 17 August 2011 08:55, Tixy <tixy at> wrote:
> > For untaring kernel source on one of my good performance
> > SD cards on a Beagleboard-xM takes:
> >
> >         m  s
> > ext4     3:30
> > ext3     8:30
> > ext2     5:00
> > btrfs   13:40
> > nilfs   10:40
> > logfs   10:00
> >
> > this is using default mount options for file system but with noatime.
> >
> > These timings also bear out preliminary results from my simulation code.
> > Which I'm glad of :-)
> This is odd. When I performed tests btrfs and ext4 were both about the
> same speed for copying a mixture of large and small files to.

Mystery solved...

I didn't have btrfs-tools (nor nilfs nor logfs) installed. My test
script didn't notice that mkfs failed because I was piping the output
through tee, (which, being the end of the pipeline, always gave a
success result).

This all resulted in my tests being re-run on the last file system
(ext2) which is a interesting result in itself as it shows a lot worse
performance compared to a fresh partition. (This is the sort of thing we
expected and is on the list of things to investigate further.)
My new results for the untar on a Beagleboard-xM...

ext4	161s
ext3	547s
ext2	256s
btrfs	139s
nilfs	157s

I couldn't test logfs because, whilst mkfs worked, the mount command (or
the kernel?) doesn't seem to support it.

I also tested the different btrfs mount options (ssd, nossd and
ssd_spread). They don't show much difference with the untar case.


More information about the linaro-dev mailing list