ux500 : ethernet not working ?

Lee Jones lee.jones at linaro.org
Mon Mar 19 13:42:45 UTC 2012


On 19/03/12 13:37, Daniel Lezcano wrote:
> On 03/19/2012 01:39 PM, Lee Jones wrote:
>> On 18/03/12 14:35, Daniel Lezcano wrote:
>>> On 03/17/2012 11:53 PM, Daniel Lezcano wrote:
>>>
>>> I also noticed the traces:
>>>
>>> [    5.231567] smsc911x: Driver version 2008-10-21
>>> [    5.236236] smsc911x smsc911x.0: Failed to get supply 'vdd33a': -19
>>> [    5.242523] smsc911x smsc911x.0: (unregistered net_device): couldn't
>>> get regulators -19
>>
>> That's right. Ethernet is not support in the Mainline kernel yet.
>>
>> It's on my TODO to complete for the next cycle.
> 
> Ok thanks for answering.
> 
> I noticed there is some work around this in mainline. I don't know the
> regulators part but maybe that could raise some interests for you.
> 
> http://www.spinics.net/lists/linux-omap/msg59647.html

Yep, this is something I plan to fix shortly.

All should be working by v3.5.

Kind regards,
Lee

> Regards,
> 
>   -- Daniel
> 
> 
>> Kind regards,
>> Lee
>>
>>>> Hi,
>>>>
>>>> I am not succeeding to make ethernet to work on a 3.3-rc6 for the
>>>> snowball.
>>>>
>>>> I noticed the same problem occured a few versions ago and was fixed
>>>> [1].
>>>> But it seems some modification around the fix location was made for
>>>> the 3.3 and perhaps resulted on a new regression.
>>>>
>>>> Was this problem already spotted for this version ? Is there a patch
>>>> in this case ?
>>>>
>>>> Thanks
>>>> -- Daniel
>>>>
>>>> [1] https://bugs.launchpad.net/linaro-landing-team-ste/+bug/804209
>>>>
>>>
>>>
>>
>>
> 
> 


-- 
Lee Jones
Linaro ST-Ericsson Landing Team Lead
M: +44 77 88 633 515
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog



More information about the linaro-dev mailing list