This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "".
The branch, master has been updated
via b007f9d72b085005ba7b19355885c7f0096899e2 (commit)
from b6a5e7039cc23e4547b11b78a12ba7f9efe6ae93 (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit b007f9d72b085005ba7b19355885c7f0096899e2
Author: Maxim Uvarov <maxim.uvarov(a)linaro.org>
Date: Fri Jul 29 17:58:24 2016 +0300
linux-gen: fix possible overflow in pktio ipc code
Add additional check before coping from pointer to
array for pool name. In general it should never happen
until somebody will corrupt shared memory.
https://bugs.linaro.org/show_bug.cgi?id=2424
Signed-off-by: Maxim Uvarov <maxim.uvarov(a)linaro.org>
Reviewed-by: Bill Fischofer <bill.fischofer(a)linaro.org>
diff --git a/platform/linux-generic/pktio/ipc.c b/platform/linux-generic/pktio/ipc.c
index f9e7a00..d97e495 100644
--- a/platform/linux-generic/pktio/ipc.c
+++ b/platform/linux-generic/pktio/ipc.c
@@ -211,6 +211,12 @@ static int _ipc_init_master(pktio_entry_t *pktio_entry,
/* Set up pool name for remote info */
pinfo = pktio_entry->s.ipc.pinfo;
pool_name = _ipc_odp_buffer_pool_shm_name(pool);
+ if (strlen(pool_name) > ODP_POOL_NAME_LEN) {
+ ODP_DBG("pid %d ipc pool name %s is too big %d\n",
+ getpid(), pool_name, strlen(pool_name));
+ goto free_s_prod;
+ }
+
memcpy(pinfo->master.pool_name, pool_name, strlen(pool_name));
pinfo->master.shm_pkt_pool_size = pool_entry->s.pool_size;
pinfo->master.shm_pool_bufs_num = pool_entry->s.buf_num;
-----------------------------------------------------------------------
Summary of changes:
platform/linux-generic/pktio/ipc.c | 6 ++++++
1 file changed, 6 insertions(+)
hooks/post-receive
--
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "".
The branch, master has been updated
via b6a5e7039cc23e4547b11b78a12ba7f9efe6ae93 (commit)
via 4c759ad5c0a4d1ece38b5cd93c24faddee9d5292 (commit)
from 014a7fab6a34aacb061e53cc0b14d12aa119b03a (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit b6a5e7039cc23e4547b11b78a12ba7f9efe6ae93
Author: Nikhil Agarwal <nikhil.agarwal(a)linaro.org>
Date: Fri Jul 29 20:08:58 2016 +0530
api:crypto: resolve todo items
odp_session_proc_info_t is no longer required.
Clarified hash_result_offset and its relation with ICV value.
Signed-off-by: Nikhil Agarwal <nikhil.agarwal(a)linaro.org>
Reviewed-by: Bill Fischofer <bill.fischofer(a)linaro.org>
Signed-off-by: Maxim Uvarov <maxim.uvarov(a)linaro.org>
diff --git a/include/odp/api/spec/crypto.h b/include/odp/api/spec/crypto.h
index d8123e9..dea1fe9 100644
--- a/include/odp/api/spec/crypto.h
+++ b/include/odp/api/spec/crypto.h
@@ -170,8 +170,6 @@ typedef struct odp_crypto_data_range {
/**
* Crypto API session creation parameters
- *
- * @todo Add "odp_session_proc_info_t"
*/
typedef struct odp_crypto_session_params {
odp_crypto_op_t op; /**< Encode versus decode */
@@ -210,8 +208,6 @@ typedef struct odp_crypto_session_params {
/**
* Crypto API per packet operation parameters
- *
- * @todo Clarify who zero's ICV and how this relates to "hash_result_offset"
*/
typedef struct odp_crypto_op_params {
odp_crypto_session_t session; /**< Session handle from creation */
@@ -245,6 +241,14 @@ typedef struct odp_crypto_op_params {
* indicates the caller wishes the destination packet buffer be allocated
* from the output pool specified during session creation.
*
+ * @var odp_crypto_op_params_t::hash_result_offset
+ *
+ * Specifies the offset where the hash result is to be stored. In case of
+ * decode sessions, input hash values will be read from this offset, and
+ * overwritten with hash results. If this offset lies within specified
+ * auth_range, implementation will mute this field before calculating the hash
+ * result.
+ *
* @sa odp_crypto_session_params_t::output_pool.
*/
commit 4c759ad5c0a4d1ece38b5cd93c24faddee9d5292
Author: Nikhil Agarwal <nikhil.agarwal(a)linaro.org>
Date: Fri Jul 29 20:08:57 2016 +0530
example:ipsec: removed invalid todos.
This todo item is no longer valid.
Fixed as a part of following work card.
https://cards.linaro.org/browse/LNG-857
Signed-off-by: Nikhil Agarwal <nikhil.agarwal(a)linaro.org>
Reviewed-by: Bill Fischofer <bill.fischofer(a)linaro.org>
Signed-off-by: Maxim Uvarov <maxim.uvarov(a)linaro.org>
diff --git a/example/ipsec/odp_ipsec_stream.h b/example/ipsec/odp_ipsec_stream.h
index ea480c3..6f6f7df 100644
--- a/example/ipsec/odp_ipsec_stream.h
+++ b/example/ipsec/odp_ipsec_stream.h
@@ -93,10 +93,6 @@ odp_packet_t create_ipv4_packet(stream_db_entry_t *stream,
/**
* Verify an IPv4 packet received on a loop output queue
*
- * @todo Better error checking, add counters, add tracing,
- * remove magic numbers, add order verification
- * (see https://bugs.linaro.org/show_bug.cgi?id=620)
- *
* @param stream Stream to verify the packet against
* @param pkt Packet to verify
*
-----------------------------------------------------------------------
Summary of changes:
example/ipsec/odp_ipsec_stream.h | 4 ----
include/odp/api/spec/crypto.h | 12 ++++++++----
2 files changed, 8 insertions(+), 8 deletions(-)
hooks/post-receive
--
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "".
The branch, master has been updated
via 014a7fab6a34aacb061e53cc0b14d12aa119b03a (commit)
via 48272fd98f3882a708a7302cd4e28308d59f96e9 (commit)
via e63a6cc10819fccbc55ec55d4585e0619463320b (commit)
from 2b5e5bdfc8b650feba79ccd23c175fad16fd2b33 (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
-----------------------------------------------------------------------
Summary of changes:
include/odp/api/spec/system_info.h | 4 ++--
include/odp/api/spec/traffic_mngr.h | 11 ++++++++---
platform/linux-generic/include/odp_traffic_mngr_internal.h | 2 +-
platform/linux-generic/odp_traffic_mngr.c | 8 +++++++-
test/common_plat/validation/api/traffic_mngr/traffic_mngr.c | 8 ++++----
5 files changed, 22 insertions(+), 11 deletions(-)
hooks/post-receive
--
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "".
The branch, api-next has been updated
via 414c4c75b0beb8cd4e4d2abe090921bcf058ec69 (commit)
via 2b5e5bdfc8b650feba79ccd23c175fad16fd2b33 (commit)
from 2c494b4a67123c838b4b6915679cca06f9e0bdd2 (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit 414c4c75b0beb8cd4e4d2abe090921bcf058ec69
Merge: 2c494b4 2b5e5bd
Author: Maxim Uvarov <maxim.uvarov(a)linaro.org>
Date: Wed Jul 27 19:21:41 2016 +0300
Merge branch 'master' into api-next
Signed-off-by: Maxim Uvarov <maxim.uvarov(a)linaro.org>
-----------------------------------------------------------------------
Summary of changes:
platform/linux-generic/arch/default/odp/api/cpu_arch.h | 10 +---------
platform/linux-generic/arch/mips64/odp/api/cpu_arch.h | 12 +++---------
platform/linux-generic/arch/powerpc/odp/api/cpu_arch.h | 10 +---------
platform/linux-generic/arch/x86/odp/api/cpu_arch.h | 10 +---------
platform/linux-generic/include/odp/api/align.h | 11 ++++-------
5 files changed, 10 insertions(+), 43 deletions(-)
hooks/post-receive
--
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "".
The branch, api-next has been updated
via 2c494b4a67123c838b4b6915679cca06f9e0bdd2 (commit)
via e6fd300ada7529c9ae454c2ce537844a1c822d21 (commit)
from bbb10c23626657723466a42b94612b554858ce1d (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit 2c494b4a67123c838b4b6915679cca06f9e0bdd2
Merge: bbb10c2 e6fd300
Author: Maxim Uvarov <maxim.uvarov(a)linaro.org>
Date: Tue Jul 26 19:03:43 2016 +0300
Merge branch 'master' into api-next
Signed-off-by: Maxim Uvarov <maxim.uvarov(a)linaro.org>
-----------------------------------------------------------------------
Summary of changes:
platform/linux-generic/odp_pool.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
hooks/post-receive
--
This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "".
The branch, master has been updated
via e6fd300ada7529c9ae454c2ce537844a1c822d21 (commit)
from 870ef79d2dae0ad94a5079d0ca1e222493937aef (commit)
Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.
- Log -----------------------------------------------------------------
commit e6fd300ada7529c9ae454c2ce537844a1c822d21
Author: Maxim Uvarov <maxim.uvarov(a)linaro.org>
Date: Tue Jul 26 18:05:00 2016 +0300
linux-gen: fix odp_pool_print
commit: ec0d570 linux-gen: pool: optimize thread local buffer cache
removed elements for prints but did not remove that
from format string.
Signed-off-by: Maxim Uvarov <maxim.uvarov(a)linaro.org>
diff --git a/platform/linux-generic/odp_pool.c b/platform/linux-generic/odp_pool.c
index 0a427ed..415c9fa 100644
--- a/platform/linux-generic/odp_pool.c
+++ b/platform/linux-generic/odp_pool.c
@@ -1103,7 +1103,7 @@ void odp_pool_print(odp_pool_t pool_hdl)
odp_shm_to_u64(pool->s.pool_shm));
ODP_DBG(" pool status %s\n",
pool->s.quiesced ? "quiesced" : "active");
- ODP_DBG(" pool opts %s, %s, %s\n",
+ ODP_DBG(" pool opts %s, %s\n",
pool->s.flags.unsegmented ? "unsegmented" : "segmented",
pool->s.flags.predefined ? "predefined" : "created");
ODP_DBG(" pool base %p\n", pool->s.pool_base_addr);
-----------------------------------------------------------------------
Summary of changes:
platform/linux-generic/odp_pool.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
hooks/post-receive
--