On 20-01-16, 16:20, Stephen Boyd wrote:
Ok, first off, I don't understand why the regulator and clock pointers are in the struct device_opp instead of the struct device_list_opp. I thought we wanted to make it possible for two devices to share the same OPP table (device_opp), but have physically different clocks and regulators (non opp-shared case)? If we put the clock and regulator handles in the device_opp then the opp table is limited to one device or a set of devices that all share the same clock and regulators.
Not exactly. We wanted devices (with separate rails) to share the OPP tables ONLY IN DT. So that the same thing isn't required to be copied multiple times in DT, for example in case of Krait.
But the code isn't supposed to shared device_opp structure at all. There is one device_opp structure for a groups of devices that share their OPPs and their clock/voltage rails. opp_device_list is representing individual devices that share the same device_opp thing.
And this works pretty well and I don't think we should touch it now.
BTW, these structure names confuse me all the time. I have to rename dev_pm_opp to opp_entry, device_opp to opp_table, and device_list_opp to opp_device_list in my head for anything to make sense.
Sure, we can (should) rename them after this series goes in.
Gripes aside, the clock and regulator pointers should never be 'put' and go away until the device driver that's using the dev_pm_opp_set_rate() API has called dev_pm_opp_remove().
Right.
So any concerns about that happening during an OPP switch aren't the concern of the OPP framework, but the concern of the consumer drivers having the proper locking and tear down sequences.
I am fine with that view as well.. It simplifies lots of things for me :)