On 14/03/06, AKASHI Takahiro wrote:
On 03/01/2014 01:15 AM, Will Deacon wrote:
On Fri, Feb 28, 2014 at 05:17:15AM +0000, AKASHI Takahiro wrote:
This patch adds auditing functions on entry to or exit from every system call invocation.
Acked-by: Richard Guy Briggs rgb@redhat.com Signed-off-by: AKASHI Takahiro takahiro.akashi@linaro.org
arch/arm64/kernel/ptrace.c | 54 ++++++++++++++++++++++++++------------------ 1 file changed, 32 insertions(+), 22 deletions(-)
I think you need to do something like I did for arch/arm/, where we have separate trace functions for entry/exit to make sure that we invoke the various helpers in the correct order (for example, you want to invoke all the debug stuff *first* on entry, but *last* on exit).
Will
If you mean syscall_trace_enter()/exit(), I will follow your suggestion for readability.
It isn't so much a question of readability, but rather correctness, undoing operations in the opposite order on exit that they were done on entry.
-Takahiro AKASHI
- RGB
-- Richard Guy Briggs rbriggs@redhat.com Senior Software Engineer, Kernel Security, AMER ENG Base Operating Systems, Red Hat Remote, Ottawa, Canada Voice: +1.647.777.2635, Internal: (81) 32635, Alt: +1.613.693.0684x3545