On Mon, Sep 12, 2016 at 09:47:48AM +0200, Vincent Guittot wrote:
@@ -3690,7 +3658,7 @@ entity_tick(struct cfs_rq *cfs_rq, struct sched_entity *curr, int queued) /* * Ensure that runnable average is periodically updated. */
- update_load_avg(curr, 1);
- update_load_avg(curr, 1, 0); update_cfs_shares(cfs_rq);
I would find something like: update_load_avg(curr, UPDATE_TG), eg, make the second argument a bitflag instead of two arguments, much more readable.
Do however check that it doesn't generate retarded code if you do that.