On Mon, Oct 07, 2013 at 08:48:23AM -0700, Victor Kamensky wrote:
-#define ASID(mm) ((mm)->context.id.counter & ~ASID_MASK) +#define ASID(mm) ((unsigned int)((mm)->context.id.counter & ~ASID_MASK))
Not a big problem, but "unsigned" is sufficient as per my suggestion. See:
http://en.wikipedia.org/wiki/C_data_types
or look it up in the C standards. :) I'll take it either way.