Hi,
this patchset provides some cleanups to prepare the removal of the CPUIDLE_DRIVER_STATE_START macro in the cpuidle code. As the code has built on top of this macro adding more complexity and ugly hacks/tricks, it is hard to simply remove it. Some code has to be cleanup before, this is the purpose of this first patchset.
Changelog:
V3: - fixed comment for the latency_req introduction back to the right patch - added back the last_idx_state in the reflect function - change the get_typical_interval to return the value
V2: - fixed typo - removed redundant comment - fixed readability
Daniel Lezcano (6): sched: idle: Add a weak arch_cpu_idle_poll function sched: idle: cpuidle: Check the latency req before idle sched: idle: Get the next timer event and pass it the cpuidle framework cpuidle: idle: menu: Don't reflect when a state selection failed cpuidle: menu: Fix the get_typical_interval cpuidle: menu: Move the update function before its declaration
drivers/cpuidle/cpuidle.c | 12 +-- drivers/cpuidle/governors/ladder.c | 13 +-- drivers/cpuidle/governors/menu.c | 183 ++++++++++++++++++------------------- include/linux/cpuidle.h | 9 +- kernel/sched/idle.c | 55 +++++++---- 5 files changed, 140 insertions(+), 132 deletions(-)