On Fri, Jun 18, 2021, at 9:31 AM, Mathieu Desnoyers wrote:
----- On Jun 17, 2021, at 8:12 PM, Andy Lutomirski luto@kernel.org wrote:
On 6/17/21 7:47 AM, Mathieu Desnoyers wrote:
Please change back this #ifndef / #else / #endif within function for
if (!IS_ENABLED(CONFIG_ARCH_HAS_MEMBARRIER_SYNC_CORE)) { ... } else { ... }
I don't think mixing up preprocessor and code logic makes it more readable.
I agree, but I don't know how to make the result work well. membarrier_sync_core_before_usermode() isn't defined in the !IS_ENABLED case, so either I need to fake up a definition or use #ifdef.
If I faked up a definition, I would want to assert, at build time, that it isn't called. I don't think we can do:
static void membarrier_sync_core_before_usermode() { BUILD_BUG_IF_REACHABLE(); }
Let's look at the context here:
static void ipi_sync_core(void *info) { [....] membarrier_sync_core_before_usermode() }
^ this can be within #ifdef / #endif
static int membarrier_private_expedited(int flags, int cpu_id) [...] if (!IS_ENABLED(CONFIG_ARCH_HAS_MEMBARRIER_SYNC_CORE)) return -EINVAL; if (!(atomic_read(&mm->membarrier_state) & MEMBARRIER_STATE_PRIVATE_EXPEDITED_SYNC_CORE_READY)) return -EPERM; ipi_func = ipi_sync_core;
All we need to make the line above work is to define an empty ipi_sync_core function in the #else case after the ipi_sync_core() function definition.
Or am I missing your point ?
Maybe?
My objection is that an empty ipi_sync_core is a lie — it doesn’t sync the core. I would be fine with that if I could have the compiler statically verify that it’s not called, but I’m uncomfortable having it there if the implementation is actively incorrect.