5.15-stable review patch. If anyone has any objections, please let me know.
------------------
From: Tobias Klauser tklauser@distanz.ch
[ Upstream commit 1b699bf3a8786f7d41eebd9f6ba673185fa5b6bd ]
Use netif_is_bridge_port defined in <linux/netdevice.h> instead of open-coding it.
Acked-by: Namjae Jeon linkinjeon@kernel.org Signed-off-by: Tobias Klauser tklauser@distanz.ch Signed-off-by: Steve French stfrench@microsoft.com Signed-off-by: Greg Kroah-Hartman gregkh@linuxfoundation.org --- fs/ksmbd/transport_tcp.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
--- a/fs/ksmbd/transport_tcp.c +++ b/fs/ksmbd/transport_tcp.c @@ -505,7 +505,7 @@ static int ksmbd_netdev_event(struct not
switch (event) { case NETDEV_UP: - if (netdev->priv_flags & IFF_BRIDGE_PORT) + if (netif_is_bridge_port(netdev)) return NOTIFY_OK;
list_for_each_entry(iface, &iface_list, entry) { @@ -614,7 +614,7 @@ int ksmbd_tcp_set_interfaces(char *ifc_l
rtnl_lock(); for_each_netdev(&init_net, netdev) { - if (netdev->priv_flags & IFF_BRIDGE_PORT) + if (netif_is_bridge_port(netdev)) continue; if (!alloc_iface(kstrdup(netdev->name, GFP_KERNEL))) return -ENOMEM;