On Fri, Jan 29, 2021 at 07:45:07PM -0800, Ilya Lipnitskiy wrote:
Also use KBUILD_MODNAME for module name.
This driver is only used by RALINK MIPS MT7621 SoCs. Tested by building against that target using OpenWrt with Linux 5.10.10.
Fixes the following error: error: the following would cause module name conflict: drivers/dma/mediatek/mtk-hsdma.ko drivers/staging/mt7621-dma/mtk-hsdma.ko
The only part of this commit message that I could understand at all was the parts which were copy and pasted from the build system... :/ Please, write it like this:
[PATCH] staging/mt7621-dma: fix build conflict
This driver cannot be built because we have two modules with the same name and it leads to an error:
error: the following would cause module name conflict: drivers/dma/mediatek/mtk-hsdma.ko drivers/staging/mt7621-dma/mtk-hsdma.ko
The fix is to rename mtk-hsdma.c to hsdma-mt7621.c. Also we can use the KBUILD_MODNAME where appropriate instead of hard coding the name.
regards, dan carpenter