diff --git a/arch/x86/kvm/svm/sev.c b/arch/x86/kvm/svm/sev.c index 273cba809328..9451de72f917 100644 --- a/arch/x86/kvm/svm/sev.c +++ b/arch/x86/kvm/svm/sev.c @@ -1294,7 +1294,7 @@ static int sev_send_update_data(struct kvm *kvm, struct kvm_sev_cmd *argp)
/* Check if we are crossing the page boundary */ offset = params.guest_uaddr & (PAGE_SIZE - 1);
if ((params.guest_len + offset > PAGE_SIZE))
if (params.guest_len > PAGE_SIZE || (params.guest_len + offset > PAGE_SIZE))
I see the original if statement had double parentheses, which looks strange. Should this if (and the one below) be:
if (params.guest_len > PAGE_SIZE || (params.guest_len + offset) > PAGE_SIZE)
Isn't the order of operations here: '+' and then '>'. So is the patch correct and matches the old conditional? I am fine adding additional () for clarity though.