Hi,
I submit v2 of Armada 7k/8k improvements. It addresses all comments from review and add some minor improvements. Details can be found in the changelog and commit logs.
The commits are also available in the github: https://github.com/MarvellEmbeddedProcessors/edk2-open-platform/commits/opp-...
Any remarks or comments will be very welcome.
Best regards, Marcin
Changelog v1 -> v2: * 1/4: Change type of COMPHY_CHIP_INIT callback to VOID and rework Status usage * 2/4: Add 'Reviewed-by' * 3/4: - Sort includes in header - Rename 'storage' to 'nondiscoverable' in all macros and names - Add defines for array sizes in definition - Add defines for base addresses, so that they describe HW block and device - Add comments for sections * 4/4: - Remove 'Ptr' suffixes - Move and rename DEV_ENABLED macro from PciEmulation driver - use it in ComPhy code - Simplify obtaining enabled Sata ports and do not return EFI_SUCCESS on PCD mismatch (lane enabled in ComPhy, despite the controller disabled) - Add macros for controller ID's - Remove unrelated style fixes - Rewrite error print information in ComPhyCp110Init, because from now we have more root causes than PLL
Konstantin Porotchkin (4): Platforms/Marvell: ComPhyLib: Fix compilation warning Platforms/Marvell: Add support for COMPHY on CP slaves Platform/Marvell: Extend and share the platform description Platform/Marvell: ComPhyLib: Enable SATA PHY init for multiple devices
Platforms/Marvell/Armada/Armada70x0.dsc | 9 +- Platforms/Marvell/Include/Library/MvHwDescLib.h | 106 ++++++++++++++++++++++ Platforms/Marvell/Library/ComPhyLib/ComPhyCp110.c | 46 ++++++---- Platforms/Marvell/Library/ComPhyLib/ComPhyLib.c | 8 +- Platforms/Marvell/Library/ComPhyLib/ComPhyLib.h | 4 +- Platforms/Marvell/Library/ComPhyLib/ComPhyLib.inf | 3 +- Platforms/Marvell/Marvell.dec | 4 - Platforms/Marvell/PciEmulation/PciEmulation.c | 52 ++--------- 8 files changed, 156 insertions(+), 76 deletions(-) create mode 100644 Platforms/Marvell/Include/Library/MvHwDescLib.h