On Wed, Apr 17, 2019 at 01:44:40PM -0500, Gustavo A. R. Silva wrote:
Make use of the struct_size() helper instead of an open-coded version in order to avoid any potential type mistakes, in particular in the context in which this code is being used.
So, replace code of the following form:
sizeof(*resp) + props_count * sizeof(struct gb_power_supply_props_desc)
with:
struct_size(resp, props, props_count)
This code was detected with the help of Coccinelle.
Signed-off-by: Gustavo A. R. Silva gustavo@embeddedor.com
Changes in v2:
- Rebase on top of 47830c1127ef ("staging: greybus: power_supply: fix prop-descriptor request size")
Thanks for rebasing.
Reviewed-by: Johan Hovold johan@kernel.org
Johan