On Thu, Aug 20, 2026 at 04:02:35PM +0530, singh.supreet14@gmail.com wrote:
From: Supreet Singh singh.supreet14@gmail.com
The return value of spi_new_device() is only used to check whether device creation succeeded. Remove the unnecessary local variable and check the return value directly.
Signed-off-by: Supreet Singh singh.supreet14@gmail.com
drivers/staging/greybus/spilib.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/greybus/spilib.c b/drivers/staging/greybus/spilib.c index 39d5bf234c61..0e8711fdc429 100644 --- a/drivers/staging/greybus/spilib.c +++ b/drivers/staging/greybus/spilib.c @@ -444,7 +444,6 @@ static int gb_spi_setup_device(struct gb_spilib *spi, u8 cs) struct gb_spi_device_config_request request; struct gb_spi_device_config_response response; struct spi_board_info spi_board = { {0} };
- struct spi_device *spidev; int ret; u8 dev_type;
@@ -480,8 +479,7 @@ static int gb_spi_setup_device(struct gb_spilib *spi, u8 cs) spi_board.chip_select = cs; spi_board.max_speed_hz = le32_to_cpu(response.max_speed_hz);
- spidev = spi_new_device(ctlr, &spi_board);
- if (!spidev)
- if (!spi_new_device(ctlr, &spi_board)) return -EINVAL;
No, this change just makes the code harder to read.
Johan