On Thu, Apr 04, 2019 at 08:09:51AM +0100, Rui Miguel Silva wrote:
Hi Gustavo, Thanks a lot for the patch.
On Wed 03 Apr 2019 at 21:58, Gustavo A. R. Silva wrote:
Make use of the struct_size() helper instead of an open-coded version in order to avoid any potential type mistakes, in particular in the context in which this code is being used.
So, replace code of the following form:
sizeof(*resp) + props_count * sizeof(struct gb_power_supply_props_desc)
with:
struct_size(resp, props, props_count)
This code was detected with the help of Coccinelle.
Signed-off-by: Gustavo A. R. Silva gustavo@embeddedor.com
What are the odds of 2 people changing same code in greybus in the same day :).
Well, I only noticed the bug in the current code, when reviewing Gustavo's diff. ;)
Johan