On 7/20/24 9:54 AM, Kees Cook wrote:
Based on feedback from Linus[1] and follow-up discussions, change the suggested file naming for KUnit tests.
Link: https://lore.kernel.org/lkml/CAHk-=wgim6pNiGTBMhP8Kd3tsB7_JTAuvNJ=XYd3wPvvk=... [1] Signed-off-by: Kees Cook kees@kernel.org
Cc: David Gow davidgow@google.com Cc: Brendan Higgins brendan.higgins@linux.dev Cc: Rae Moar rmoar@google.com Cc: John Hubbard jhubbard@nvidia.com Cc: Jonathan Corbet corbet@lwn.net Cc: Linus Torvalds torvalds@linux-foundation.org Cc: linux-kselftest@vger.kernel.org Cc: kunit-dev@googlegroups.com Cc: linux-doc@vger.kernel.org Cc: linux-kernel@vger.kernel.org Cc: linux-hardening@vger.kernel.org
Documentation/dev-tools/kunit/style.rst | 25 +++++++++++++++---------- 1 file changed, 15 insertions(+), 10 deletions(-)
diff --git a/Documentation/dev-tools/kunit/style.rst b/Documentation/dev-tools/kunit/style.rst index b6d0d7359f00..1538835cd0e2 100644 --- a/Documentation/dev-tools/kunit/style.rst +++ b/Documentation/dev-tools/kunit/style.rst @@ -188,15 +188,20 @@ For example, a Kconfig entry might look like: Test File and Module Names ========================== -KUnit tests can often be compiled as a module. These modules should be named -after the test suite, followed by ``_test``. If this is likely to conflict with -non-KUnit tests, the suffix ``_kunit`` can also be used.
-The easiest way of achieving this is to name the file containing the test suite -``<suite>_test.c`` (or, as above, ``<suite>_kunit.c``). This file should be -placed next to the code under test. +Whether a KUnit test is compiled as a separate module or via an +``#include`` in a core kernel source file, the file should be named +after the test suite, followed by ``_kunit``, and live in a ``tests`` +subdirectory to avoid conflicting with regular modules (e.g. if "foobar" +is the core module, then "foobar_kunit" is the KUnit test module) or the +core kernel source file names (e.g. for tab-completion). Many existing +tests use a ``_test`` suffix, but this is considered deprecated.
For this paragraph, may I suggest this wording below? It attempts to explain the _kunit a bit (without leaving anything behind that would need to be changed later, if/when people rename things from _test.c to _kunit.c), as well as fixing up the sentence structure slightly:
Whether a KUnit test is compiled as a separate module or via an ``#include`` in a core kernel source file, the file should be named after the test suite, followed by ``_kunit``, and live in a ``tests`` subdirectory. This is to avoid conflicting with regular modules (e.g. if "foobar" is the core module, then "foobar_kunit" is the KUnit test module) or with the core kernel source file names (e.g. for tab-completion). The ``_kunit`` suffix was chosen over the older (and now deprecated) ``_test`` suffix, because KUnit behavior is sufficiently distinct that it is worth identifying at file name level.
+So for the common case, name the file containing the test suite +``tests/<suite>_kunit.c``. The ``tests`` directory should be placed at +the same level as the code under test. For example, tests for +``lib/string.c`` live in ``lib/tests/string_kunit.c``. If the suite name contains some or all of the name of the test's parent -directory, it may make sense to modify the source filename to reduce redundancy. -For example, a ``foo_firmware`` suite could be in the ``foo/firmware_test.c`` -file. +directory, it may make sense to modify the source filename to reduce +redundancy. For example, a ``foo_firmware`` suite could be in the +``tests/foo/firmware_kunit.c`` file.
Whether you use that wording or not, this looks good, so:
Reviewed-by: John Hubbard jhubbard@nvidia.com
thanks,