On Wed, Jul 28, 2021 at 04:07:19PM +0000, David Matlack wrote:
On Tue, Jul 27, 2021 at 08:47:44PM +0000, Sean Christopherson wrote:
On Mon, Jul 26, 2021, David Matlack wrote:
On Mon, Jul 26, 2021 at 11:37:54AM -0700, Erdem Aktas wrote:
Currently vm_create function only creates KVM_X86_LEGACY_VM type VMs. Changing the vm_create function to accept type parameter to create new VM types.
Signed-off-by: Erdem Aktas erdemaktas@google.com Reviewed-by: Sean Christopherson seanjc@google.com
*-by tags should not be added unless explicitly provided. IIRC, our internal gerrit will convert +1 to Reviewed-by, but I don't think that's the case here. This applies to all patches in this series.
See "Using Reported-by:, Tested-by:, Reviewed-by:, Suggested-by: and Fixes:" in Documentation/process/submitting-patches.rst for more info.
Reviewed-by: Peter Gonda pgonda@google.com Reviewed-by: Marc Orr marcorr@google.com Reviewed-by: Sagi Shahar sagis@google.com
Reviewed-by: David Matlack dmatlack@google.com
(aside from the nit below)
.../testing/selftests/kvm/include/kvm_util.h | 1 + tools/testing/selftests/kvm/lib/kvm_util.c | 29 +++++++++++++++++-- 2 files changed, 27 insertions(+), 3 deletions(-)
diff --git a/tools/testing/selftests/kvm/include/kvm_util.h b/tools/testing/selftests/kvm/include/kvm_util.h index d53bfadd2..c63df42d6 100644 --- a/tools/testing/selftests/kvm/include/kvm_util.h +++ b/tools/testing/selftests/kvm/include/kvm_util.h @@ -88,6 +88,7 @@ int vcpu_enable_cap(struct kvm_vm *vm, uint32_t vcpu_id, void vm_enable_dirty_ring(struct kvm_vm *vm, uint32_t ring_size); struct kvm_vm *vm_create(enum vm_guest_mode mode, uint64_t phy_pages, int perm); +struct kvm_vm *__vm_create(enum vm_guest_mode mode, uint64_t phy_pages, int perm, int type);
nit: Consider using a more readable function name such as vm_create_with_type().
Ha! This is why I don't like doing internal reviews :-D
+1 :)
Erdem originally had vm_create_type(), I suggested __vm_create() as the double underscore scheme is more common in the kernel for cases where there's a default wrapper and an inner helper that implements the full API.
Convention aside, the argument againsts ...with_type() are that it doesn't scale, e.g. if someone adds another parameter parameter for which vm_create() provides a default, and it doesn't self-document the relationship between vm_create() and the inner helper, e.g. by convention, based on names alone I know that vm_create() likely is a wrapper around __vm_create().
True, although with __vm_create() is not solving the scalability problem, it's just preventing scaling altogether (you can only have 1 wrapper function, vm_create). So if any caller wants to override one of the defaults they have to override all of them.
I agree with you though in this case: __vm_create() is a better choice (especially given the existence of vm_create_with_vcpus).
A better option than both (but would involve more work) would be to create an options struct with all optional arguments. Unfortunately C makes working with options structs a bit clumsy. But it's something to consider as the number of options passed to __vm_create increases.
For example:
struct vm_options { enum vm_guest_mode mode; uint64_t phy_pages; int perm; int type; };
struct kvm_vm *vm_create(const struct vm_options *options) { ... }
static const struct vm_options default_vm_options = { .mode = VM_MODE_DEFAULT, .phy_pages = DEFAULT_GUEST_PHY_PAGES, .perm = O_RDWR, .type = DEFAULT_VM_TYPE, };
/* Create a VM with default options. */ vm = create_vm(&default_vm_options);
/* Create a VM with TDX enabled. */ struct vm_options options = default_vm_options; options.type = VM_TYPE_TDX; vm = create_vm(&options);
I like this.
Thanks, drew