On Wed, Jun 26, 2019 at 12:53 AM Brendan Higgins brendanhiggins@google.com wrote:
On Tue, Jun 25, 2019 at 4:22 PM Luis Chamberlain mcgrof@kernel.org wrote:
On Mon, Jun 17, 2019 at 01:26:02AM -0700, Brendan Higgins wrote:
diff --git a/kunit/example-test.c b/kunit/example-test.c new file mode 100644 index 0000000000000..f44b8ece488bb --- /dev/null +++ b/kunit/example-test.c
<-- snip -->
+/*
- This defines a suite or grouping of tests.
- Test cases are defined as belonging to the suite by adding them to
- `kunit_cases`.
- Often it is desirable to run some function which will set up things which
- will be used by every test; this is accomplished with an `init` function
- which runs before each test case is invoked. Similarly, an `exit` function
- may be specified which runs after every test case and can be used to for
- cleanup. For clarity, running tests in a test module would behave as follows:
To be clear this is not the kernel module init, but rather the kunit module init. I think using kmodule would make this clearer to a reader.
Seems reasonable. Will fix in next revision.
- module.init(test);
- module.test_case[0](test);
- module.exit(test);
- module.init(test);
- module.test_case[1](test);
- module.exit(test);
- ...;
- */
Do you think it might be clearer yet to rename `struct kunit_module *module;` to `struct kunit_suite *suite;`?