This series let kunit macro more neat and clear. Fix comment and rename the macro. Also introduce new type of assertion marco for functionality. This is a follow-up to [0](v1).
v1 -> v2: [PATCH 2/3] changed KUNIT_ASSERT to KUNIT_FAIL_AND_ABORT [0] https://lore.kernel.org/lkml/20240710170448.1399967-1-ericchancf@google.com/
Eric Chan (3): kunit: Fix the comment of KUNIT_ASSERT_STRNEQ as assertion kunit: Rename KUNIT_ASSERT_FAILURE to KUNIT_FAIL_AND_ABORT for readability kunit: Introduce KUNIT_ASSERT_MEMEQ and KUNIT_ASSERT_MEMNEQ macros
drivers/input/tests/input_test.c | 2 +- include/kunit/assert.h | 2 +- include/kunit/test.h | 71 ++++++++++++++++++++++++++++++-- 3 files changed, 70 insertions(+), 5 deletions(-)