On Wed, Apr 21, 2021 at 10:04 AM Daniel Latypov dlatypov@google.com wrote:
This adds unit tests for kunit_filter_subsuite() and kunit_filter_suites().
Note: what the executor means by "subsuite" is the array of suites corresponding to each test file.
This patch lightly refactors executor.c to avoid the use of global variables to make it testable. It also includes a clever `kfree_at_end()` helper that makes this test easier to write than it otherwise would have been.
Tested by running just the new tests using itself $ ./tools/testing/kunit/kunit.py run '*exec*'
Signed-off-by: Daniel Latypov dlatypov@google.com Reviewed-by: David Gow davidgow@google.com
I tested this version as well, and it still works fine.
Thanks. -- David
v2 -> v3:
- Rename variable for filter_glob module param to avoid compiler
warnings. Couldn't think of a better name for the argument.
Neither can I: filter_glob_param is fine by me.
v1 -> v2:
- Fix missing free in kfree_subsuites_at_end()