Hi Ilpo,
On 7/13/2023 6:19 AM, Ilpo Järvinen wrote:
fill_buf's arguments can be improved in multiple ways:
Multiple functions in fill_buf have start_ptr as one of their argument which is a bit long and the extra "start" is pretty obvious when it comes to pointers.
Some of the functions take end_ptr and others size_t to indicate the end of the buffer.
Some arguments meaning buffer size are called just 's'
mem_flush() takes void * but immediately converts it to char *
Cleanup the parameters to make things simpler and more consistent:
Rename start_ptr to simply buf as it's shorter.
Replace end_ptr and s parameters with buf_size and only calculate end_ptr in the functions that truly use it.
Make mem_flush() parameters to follow the same convention as the other functions in fill_buf.
convert mem_flush() char * to unsigned char *.
While at it, fix also a typo in a comment.
Signed-off-by: Ilpo Järvinen ilpo.jarvinen@linux.intel.com
This makes the code significantly easier to read. Thank you.
Reviewed-by: Reinette Chatre reinette.chatre@intel.com
Reinette