On Fri, 2024-04-12 at 16:37 -0700, Jakub Kicinski wrote:
+def ping_v4(cfg) -> None:
- if not cfg.v4:
raise KsftXfailEx()
- cmd(f"ping -c 1 -W0.5 {cfg.ep_v4}")
- cmd(f"ping -c 1 -W0.5 {cfg.v4}", host=cfg.endpoint)
Very minor nit, I personally find a bit more readable:
cfg.endpoint.cmd()
Which is already supported by the current infra, right?
With both endpoint possibly remote could be:
cfg.ep1.cmd() cfg.ep2.cmd()
Thanks!
Paolo