On Mon, Apr 19, 2021 at 01:21:56PM +0100, Matthew Wilcox wrote:
On Mon, Apr 19, 2021 at 02:56:17PM +0300, Mike Rapoport wrote:
With that fixed, you'll have a head page that you can use for testing, which means you don't need to test PageCompound() (because you know the page isn't PageTail), you can just test PageHead().
I can't say I follow you here. page_is_secretmem() is intended to be a generic test, so I don't see how it will get PageHead() if it is called from other places.
static inline bool head_is_secretmem(struct page *head) { if (PageHead(head)) return false; ... }
static inline bool page_is_secretmem(struct page *page) { if (PageTail(page)) return false; return head_is_secretmem(page); }
(yes, calling it head is a misnomer, because it's not necessarily a head, it might be a base page, but until we have a name for pages which might be a head page or a base page, it'll have to do ...)
To me this looks less clean and readable and in the end we have an extra check for PG_Head if that won't get optimized away.
Does not seem to me there would be a measurable difference, but if this is important for future conversion to folio I don't mind using {head,page}_is_secretmem.