On Fri, Feb 25, 2022 at 8:29 PM David Gow davidgow@google.com wrote:
@@ -292,11 +290,11 @@ def add_common_opts(parser) -> None: help='Path to Kconfig fragment that enables KUnit tests.' ' If given a directory, (e.g. lib/kunit), "/.kunitconfig" ' 'will get automatically appended.',
metavar='kunitconfig')
metavar='KUNITCONFIG')
Is it worth making this something like FILE or PATH instead. PATH_TO_KUNITCONFIG would be verbose, but this is a path being given, so just KUNITCONFIG is still a bit useless.
Here's what the complete help output looks like right now: --kunitconfig KUNITCONFIG Path to Kconfig fragment that enables KUnit tests. If given a directory, (e.g. lib/kunit), "/.kunitconfig" will get automatically appended.
So I didn't think it mattered too much if we left it as-is. But I like PATH (since users can use a dir, FILE felt potentially misleading, even if technically correct).
Will send a v2 with the typo in the commit fixed and this changed to PATH.