On Mon, Sep 25, 2023 at 02:17:37PM +0800, Yi Liu wrote:
yes. It is just what the existing domain_alloc_user op does. Here we add a hwpt_type as the type can be given by user, so we need to define a specific type for it.
Perhaps we can also name it as IOMMU_HWPT_TYPE_UNMANAGED to be aligned with
unmanged is also a weird nonsense name these days. We are slowly replacing it with paging.
the domain type naming. IOMMU_HWPT_TYPE_GENERIC is also a good choice. Please feel free let me know your preference.
This seems OK to me so far
Jason