On Tue, Oct 8, 2019 at 11:15 AM Kees Cook keescook@chromium.org wrote:
On Tue, Oct 08, 2019 at 10:48:37AM -0700, Brendan Higgins wrote:
On Mon, Oct 07, 2019 at 02:36:33PM -0700, David Gow wrote:
This change adds a KUnit test for the kernel doubly linked list implementation in include/linux/list.h
Note that, at present, it only tests the list_ types (not the singly-linked hlist_), and does not yet test all of the list_for_each_entry* macros (and some related things like list_prepare_entry).
This change depends on KUnit, so should be merged via the 'test' branch: https://git.kernel.org/pub/scm/linux/kernel/git/shuah/linux-kselftest.git/lo...
Signed-off-by: David Gow davidgow@google.com
lib/Kconfig.debug | 12 + lib/Makefile | 3 + lib/list-test.c | 711 ++++++++++++++++++++++++++++++++++++++++++++++ 3 files changed, 726 insertions(+) create mode 100644 lib/list-test.c
Also, I think it might be good to make a MAINTAINERs entry for this test.
Another thought, though maybe this is already covered and I missed the "best practices" notes on naming conventions.
As the "one-off" tests are already named "foo_test.c" it seems like KUnit tests should be named distinctly. Should this be lib/kunit-list.c, lib/list-kunit.c, or something else?
So we already had a discussion on this here: https://patchwork.kernel.org/patch/10925861/
(Sounds like I should have probably documented that :-))
However, I am sympathetic to your argument. I was thinking that it might be good to make get_maintainer suggest CC'ing kunit-dev@ and linux-kselftest@ for all new tests and this would be hard with the *-test.c naming scheme.
If we are going to change it, now is probably the time to do it :-)
For internal naming of structs and tests, should things be named "kunit_foo"? Examples here would be kunit_list_struct and kunit_list_test_...
I had generally been following the pattern:
foo.c struct foo_bar {}; int foo_baz() {} foo-test.c struct foo_test_buzz {}; void foo_test_does_foo_baz_buzz(struct kunit *test) {}
However, now that you point that out I am realizing there is a bunch of stuff here that is not consistent with that (whoops, sorry for not catching that earlier, David).
Nevertheless, I think the list_test_struct is fine and conforms to the pattern.
When testing other stuff, should only exposed interfaces be tested? Many things have their API exposed via registration of a static structure of function pointers to static functions. What's the proposed best way to get at that? Should the KUnit tests is IN the .c file that declares all the static functions?
Yeah, that is a good point, but I don't think entirely relevant to this code review.
Fundamentally it boils down to figuring out what your API is, and coming up with a way to expose it. For drivers, that means finding a way to give KUnit access to the generated driver objects, in some cases it means using more dependency injection, in other cases it may mean making something that is static, not static.
I know those answers sound pretty unsatisfying, and I have some features planned which alleviate some of those issues, but I think the most important thing is making examples of how to deal with some of the broad cases, getting agreement on them, documenting them, finding exceptions and iterating.
Nevertheless, if you want to start enumerating cases and proposed solutions, I would be more than happy to have that conversation now, but we might want to fork the discussion.
Cheers!