From: Jason Gunthorpe jgg@nvidia.com Sent: Saturday, February 11, 2023 5:00 AM
+struct iommu_device_info {
- __u32 size;
- __u32 flags;
- __u32 dev_id;
- __u32 data_len;
- __aligned_u64 data_ptr;
moving forward iommu hw cap is not the only information reported via this interface, e.g. it can be also used to report pasid mode.
from this angle it's better to rename above two fields to be iommu specific, e.g.:
__u32 iommu_data_len; __aligned_u64 iommu_data_ptr;
maybe call it hw info
that is fine given we already have 'struct iommu_device_info'.
probably this cmd should be named as IOMMU_DEVIEC_GET_IOMMU_INFO to be more accurate.