Rename ip_len to payload_len since the length in this case refers only to the payload, and not the entire IP packet like for IPv4. While we're at it, just use the variable directly when calling recv_verify_packet_udp/tcp.
Signed-off-by: Sean Anderson sean.anderson@linux.dev ---
tools/testing/selftests/net/lib/csum.c | 12 +++++------- 1 file changed, 5 insertions(+), 7 deletions(-)
diff --git a/tools/testing/selftests/net/lib/csum.c b/tools/testing/selftests/net/lib/csum.c index e0a34e5e8dd5..27437590eeb5 100644 --- a/tools/testing/selftests/net/lib/csum.c +++ b/tools/testing/selftests/net/lib/csum.c @@ -675,22 +675,20 @@ static int recv_verify_packet_ipv6(void *nh, int len) { struct ipv6hdr *ip6h = nh; uint16_t proto = cfg_encap ? IPPROTO_UDP : cfg_proto; - uint16_t ip_len; + uint16_t payload_len;
if (len < sizeof(*ip6h) || ip6h->nexthdr != proto) return -1;
- ip_len = ntohs(ip6h->payload_len); - if (ip_len > len - sizeof(*ip6h)) + payload_len = ntohs(ip6h->payload_len); + if (payload_len > len - sizeof(*ip6h)) return -1;
- len = ip_len; iph_addr_p = &ip6h->saddr; - if (proto == IPPROTO_TCP) - return recv_verify_packet_tcp(ip6h + 1, len); + return recv_verify_packet_tcp(ip6h + 1, payload_len); else - return recv_verify_packet_udp(ip6h + 1, len); + return recv_verify_packet_udp(ip6h + 1, payload_len); }
/* return whether auxdata includes TP_STATUS_CSUM_VALID */
Sean Anderson wrote:
Rename ip_len to payload_len since the length in this case refers only to the payload, and not the entire IP packet like for IPv4. While we're at it, just use the variable directly when calling recv_verify_packet_udp/tcp.
Signed-off-by: Sean Anderson sean.anderson@linux.dev
Not sure such refactoring patches are worth the effort.
On 9/30/24 13:16, Willem de Bruijn wrote:
Sean Anderson wrote:
Rename ip_len to payload_len since the length in this case refers only to the payload, and not the entire IP packet like for IPv4. While we're at it, just use the variable directly when calling recv_verify_packet_udp/tcp.
Signed-off-by: Sean Anderson sean.anderson@linux.dev
Not sure such refactoring patches are worth the effort.
Well, FWIW you commented on this in your review, so I figured I'd send it.
https://lore.kernel.org/all/66dbb4fcbf560_2af86229423@willemb.c.googlers.com...
--Sean
Sean Anderson wrote:
On 9/30/24 13:16, Willem de Bruijn wrote:
Sean Anderson wrote:
Rename ip_len to payload_len since the length in this case refers only to the payload, and not the entire IP packet like for IPv4. While we're at it, just use the variable directly when calling recv_verify_packet_udp/tcp.
Signed-off-by: Sean Anderson sean.anderson@linux.dev
Not sure such refactoring patches are worth the effort.
Well, FWIW you commented on this in your review, so I figured I'd send it.
https://lore.kernel.org/all/66dbb4fcbf560_2af86229423@willemb.c.googlers.com...
True. I meant if respun.
Whether such changes are worth it as standalone patch is subjective. And I get where you're coming from, given that thread.
Reviewed-by: Willem de Bruijn willemb@google.com
Hello:
This patch was applied to netdev/net-next.git (main) by Jakub Kicinski kuba@kernel.org:
On Mon, 30 Sep 2024 12:29:34 -0400 you wrote:
Rename ip_len to payload_len since the length in this case refers only to the payload, and not the entire IP packet like for IPv4. While we're at it, just use the variable directly when calling recv_verify_packet_udp/tcp.
Signed-off-by: Sean Anderson sean.anderson@linux.dev
[...]
Here is the summary with links: - [net-next] selftests: net: csum: Clean up recv_verify_packet_ipv6 https://git.kernel.org/netdev/net-next/c/d772cc25ccf7
You are awesome, thank you!
linux-kselftest-mirror@lists.linaro.org