Hi,
These trivial fixes apply to today's linux.git (5.4-rc3, or maybe -rc4, by the time I send this).
I found these while polishing up the Next And Final get_user_pages()+dma tracking patchset (which is in final testing and passing nicely...so far).
Anyway, as these two patches apply cleanly both before and after the larger gup/dma upcoming patchset, I thought it best to send this out separately, in order to avoid muddying the waters more than usual.
Cc: Christoph Hellwig hch@lst.de Cc: Aneesh Kumar K.V aneesh.kumar@linux.ibm.com Cc: Kirill A. Shutemov kirill.shutemov@linux.intel.com Cc: Keith Busch keith.busch@intel.com Cc: Shuah Khan shuah@kernel.org Cc: linux-kselftest@vger.kernel.org
John Hubbard (2): mm/gup_benchmark: add a missing "w" to getopt string mm/gup: fix a misnamed "write" argument: should be "flags"
mm/gup.c | 12 +++++++----- tools/testing/selftests/vm/gup_benchmark.c | 2 +- 2 files changed, 8 insertions(+), 6 deletions(-)
Even though gup_benchmark.c has code to handle the -w command-line option, the "w" is not part of the getopt string. It looks as if it has been missing the whole time.
On my machine, this leads naturally to the following predictable result:
$ sudo ./gup_benchmark -w ./gup_benchmark: invalid option -- 'w'
...which is fixed, with this commit.
Cc: Kirill A. Shutemov kirill.shutemov@linux.intel.com Cc: Keith Busch keith.busch@intel.com Cc: Shuah Khan shuah@kernel.org Cc: linux-kselftest@vger.kernel.org Signed-off-by: John Hubbard jhubbard@nvidia.com --- tools/testing/selftests/vm/gup_benchmark.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/testing/selftests/vm/gup_benchmark.c b/tools/testing/selftests/vm/gup_benchmark.c index c0534e298b51..cb3fc09645c4 100644 --- a/tools/testing/selftests/vm/gup_benchmark.c +++ b/tools/testing/selftests/vm/gup_benchmark.c @@ -37,7 +37,7 @@ int main(int argc, char **argv) char *file = "/dev/zero"; char *p;
- while ((opt = getopt(argc, argv, "m:r:n:f:tTLUSH")) != -1) { + while ((opt = getopt(argc, argv, "m:r:n:f:tTLUwSH")) != -1) { switch (opt) { case 'm': size = atoi(optarg) * MB;
On Sun, Oct 13, 2019 at 03:11:54PM -0700, John Hubbard wrote:
Even though gup_benchmark.c has code to handle the -w command-line option, the "w" is not part of the getopt string. It looks as if it has been missing the whole time.
On my machine, this leads naturally to the following predictable result:
$ sudo ./gup_benchmark -w ./gup_benchmark: invalid option -- 'w'
...which is fixed, with this commit.
Cc: Kirill A. Shutemov kirill.shutemov@linux.intel.com Cc: Keith Busch keith.busch@intel.com Cc: Shuah Khan shuah@kernel.org Cc: linux-kselftest@vger.kernel.org Signed-off-by: John Hubbard jhubbard@nvidia.com
Acked-by: Kirill A. Shutemov kirill.shutemov@linux.intel.com
linux-kselftest-mirror@lists.linaro.org