On Mon, Jul 20, 2020 at 11:23:13AM +0200, Thomas Gleixner wrote:
Andy Lutomirski email@example.com writes:
On Thu, Jul 16, 2020 at 12:31 PM Gabriel Krisman Bertazi firstname.lastname@example.org wrote: The amount of syscall entry wiring that arches need to do is IMO already a bit out of hand. Should we instead rename TIF_SECCOMP to TIF_SYSCALL_INTERCEPTION and have one generic callback that handles seccomp and this new thing?
The right way to go is to consolidate all the stupidly different entry/exit work handling implementations and have exactly one in generic code, i.e. what I posted a few days ago.
Then we can make new features only available in the generic version by hiding the new functionality in the core code and not exposing the functions to architecture implementations.
Making it easy for architectures to keep their own variant forever just proliferates the mess we have right now.
Couldn't agree more. We recently added PTRACE_SYSEMU to arm64 and I deeply regret doing that now that yet another way to rewrite the syscall number has come along. I only just untangled some of the mess in our entry code for that, so I can't say I'm looking forward to opening it right back up to support this new feature. Much better to do it in the core code instead.