Am 09.11.20 um 22:07 schrieb Bhaskar Chowdhury:
> s/falg/flag/p
>
> Signed-off-by: Bhaskar Chowdhury <unixbhaskar(a)gmail.com>
Reviewed-by: Christian König <christian.koenig(a)amd.com>
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_display.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> index 2e8a8b57639f..9223502c1e5b 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> @@ -509,7 +509,7 @@ uint32_t amdgpu_display_supported_domains(struct amdgpu_device *adev,
> * to avoid hang caused by placement of scanout BO in GTT on certain
> * APUs. So force the BO placement to VRAM in case this architecture
> * will not allow USWC mappings.
> - * Also, don't allow GTT domain if the BO doens't have USWC falg set.
> + * Also, don't allow GTT domain if the BO doens't have USWC flag set.
> */
> if ((bo_flags & AMDGPU_GEM_CREATE_CPU_GTT_USWC) &&
> amdgpu_bo_support_uswc(bo_flags) &&
> --
> 2.26.2
>
On Mon, Nov 9, 2020 at 4:19 PM Lee Jones <lee.jones(a)linaro.org> wrote:
>
> This set is part of a larger effort attempting to clean-up W=1
> kernel builds, which are currently overwhelmingly riddled with
> niggly little warnings.
>
> This set takes the running (decreasing) total from 5000 before
> [Set 1] down to 2300.
>
> Lee Jones (20):
> drm/radeon/radeon_ttm: Place declaration of 'rdev' in same clause as
> its use
> drm/radeon: Move radeon_ttm{init,fini} to shared location
> drm/radeon/radeon_fence: Demote some non-conformant kernel-doc headers
> and fix another
> drm/radeon: Move 'radeon_add_legacy_encoder' prototype to shared
> header
> drm/radeon: Move 'radeon_add_legacy_encoder's prototype to shared
> location
> drm/radeon/radeon_connectors: Strip out set but unused variable 'ret'
> drm/radeon/radeon_display: Remove unused variable 'mod'
> drm/radeon/radeon_i2c: Remove pointless function header
> drm/radeon/radeon_irq_kms: Demote non-conformant kernel-doc fix
> another
> drm/radeon/radeon_ring: Add missing function parameters 'rdev' and
> 'data'
> drm/radeon/r600: Strip out set but unused 'tmp' variables
> drm/radeon/radeon_cs: Fix a bunch of doc-rot issues
> drm/radeon/evergreen: Move 'rv770_set_clk_bypass_mode' prototype to
> shared location
> drm/radeon: Move 'radeon_pm_acpi_event_handler' prototype into shared
> header
> drm/radeon/r600d: Move 'rc600_*' prototypes into shared header
> drm/radeon/radeon_audio: Move 'dce3_2_*' prototypes to shared location
> drm/radeon/evergreend: Move 'evergreen_*' and 'sumo_*' prototypes out
> to shared location
> drm/radeon/radeon_display: Fix function doc formatting and missing
> param issues
> drm/radeon/r600: Fix a misnamed parameter description and a formatting
> issue
> drm/radeon/cik: Fix a bunch of function parameter descriptions
>
> drivers/gpu/drm/radeon/cik.c | 10 +++----
> drivers/gpu/drm/radeon/evergreen.c | 1 -
> drivers/gpu/drm/radeon/ni.c | 16 ----------
> drivers/gpu/drm/radeon/r600.c | 11 +++----
> drivers/gpu/drm/radeon/r600d.h | 14 +++++++++
> drivers/gpu/drm/radeon/radeon.h | 34 ++++++++++++++++++++++
> drivers/gpu/drm/radeon/radeon_acpi.c | 2 --
> drivers/gpu/drm/radeon/radeon_atombios.c | 5 ----
> drivers/gpu/drm/radeon/radeon_audio.c | 23 +--------------
> drivers/gpu/drm/radeon/radeon_audio.h | 12 ++++++++
> drivers/gpu/drm/radeon/radeon_combios.c | 5 ----
> drivers/gpu/drm/radeon/radeon_connectors.c | 4 +--
> drivers/gpu/drm/radeon/radeon_cs.c | 12 ++++----
> drivers/gpu/drm/radeon/radeon_display.c | 17 +++++------
> drivers/gpu/drm/radeon/radeon_encoders.c | 3 --
> drivers/gpu/drm/radeon/radeon_fence.c | 6 ++--
> drivers/gpu/drm/radeon/radeon_i2c.c | 4 ---
> drivers/gpu/drm/radeon/radeon_irq_kms.c | 6 ++--
> drivers/gpu/drm/radeon/radeon_object.c | 2 --
> drivers/gpu/drm/radeon/radeon_ring.c | 3 ++
> drivers/gpu/drm/radeon/radeon_ttm.c | 8 ++---
> drivers/gpu/drm/radeon/si.c | 6 ----
> 22 files changed, 96 insertions(+), 108 deletions(-)
Instead of just dumping everything in radeon.h, I think it would be
cleaner to add new headers that match the .c files that define them.
E.g., add evergreen.h and put all the stuff from evergreen.c in there.
Add rv770.h and add all the stuff defined in rv770.c, etc.
Alex
>
> Cc: Alex Deucher <alexander.deucher(a)amd.com>
> Cc: amd-gfx(a)lists.freedesktop.org
> Cc: "Christian König" <christian.koenig(a)amd.com>
> Cc: Daniel Vetter <daniel(a)ffwll.ch>
> Cc: David Airlie <airlied(a)linux.ie>
> Cc: dri-devel(a)lists.freedesktop.org
> Cc: Jerome Glisse <glisse(a)freedesktop.org>
> Cc: linaro-mm-sig(a)lists.linaro.org
> Cc: linux-media(a)vger.kernel.org
> Cc: report to <xorg-driver-ati(a)lists.x.org>
> Cc: Slava Grigorev <slava.grigorev(a)amd.com>
> Cc: Sumit Semwal <sumit.semwal(a)linaro.org>
> --
> 2.25.1
>
> _______________________________________________
> dri-devel mailing list
> dri-devel(a)lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel
On Mon, Nov 9, 2020 at 4:16 PM Bhaskar Chowdhury <unixbhaskar(a)gmail.com> wrote:
>
> s/falg/flag/p
>
> Signed-off-by: Bhaskar Chowdhury <unixbhaskar(a)gmail.com>
Applied. Thanks!
Alex
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_display.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> index 2e8a8b57639f..9223502c1e5b 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> @@ -509,7 +509,7 @@ uint32_t amdgpu_display_supported_domains(struct amdgpu_device *adev,
> * to avoid hang caused by placement of scanout BO in GTT on certain
> * APUs. So force the BO placement to VRAM in case this architecture
> * will not allow USWC mappings.
> - * Also, don't allow GTT domain if the BO doens't have USWC falg set.
> + * Also, don't allow GTT domain if the BO doens't have USWC flag set.
> */
> if ((bo_flags & AMDGPU_GEM_CREATE_CPU_GTT_USWC) &&
> amdgpu_bo_support_uswc(bo_flags) &&
> --
> 2.26.2
>
> _______________________________________________
> amd-gfx mailing list
> amd-gfx(a)lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/amd-gfx
On Mon, Nov 9, 2020 at 3:52 AM Bhaskar Chowdhury <unixbhaskar(a)gmail.com> wrote:
>
> s/doens't/doesn't/p
>
> Signed-off-by: Bhaskar Chowdhury <unixbhaskar(a)gmail.com>
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_display.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> index 7cc7af2a6822..a92cb137293a 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_display.c
> @@ -512,7 +512,7 @@ uint32_t amdgpu_display_supported_domains(struct amdgpu_device *adev,
> * to avoid hang caused by placement of scanout BO in GTT on certain
> * APUs. So force the BO placement to VRAM in case this architecture
> * will not allow USWC mappings.
> - * Also, don't allow GTT domain if the BO doens't have USWC falg set.
> + * Also, don't allow GTT domain if the BO doesn't have USWC falg set.
Applied. Care to send a patch to also fix the spelling of "flag"?
Thanks,
Alex
> */
> if ((bo_flags & AMDGPU_GEM_CREATE_CPU_GTT_USWC) &&
> amdgpu_bo_support_uswc(bo_flags) &&
> --
> 2.26.2
>
> _______________________________________________
> dri-devel mailing list
> dri-devel(a)lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel
Hi Lee,
> >
> > Other public functions in radeon_device.c have their prototype in
> > radeon.h - for example radeon_is_px()
> >
> > Add radeon_device_is_virtual() there so we avoiid this new header.
>
> Oh yes, I remember why this wasn't a suitable solution now:
>
> The macro "radeon_init" in radeon.h clashes with the init function of
> the same name in radeon_drv.c:
>
> In file included from drivers/gpu/drm/radeon/radeon_drv.c:53:
> drivers/gpu/drm/radeon/radeon_drv.c:620:31: error: expected identifier or ‘(’ before ‘void’
> 620 | static int __init radeon_init(void)
...
>
> How would you like me to move forward?
Fix the thousand of warnings in other places :-)
I will take a look at radeon and post a new series based on your work
with all W=1 warnings fixed.
Sam
On Sat, Nov 07, 2020 at 06:41:38PM +0000, Lee Jones wrote:
> On Sat, 07 Nov 2020, Sam Ravnborg wrote:
>
> > Hi Christian.
> >
> > > I'm not sure if we want to do some of the suggested changes to radeon.
> >
> > All patches for radeon looks good to me except "drm/radeon/radeon: Move
> > prototype into shared header".
>
> Was that the one where the prototype needs moving to radeon.h?
Yes,
Sam