This is the OpenPlatformPkg counterpart of the series
Embedded|ArmPlatformPkg: spring cleaning + DtPlatformDxe switch
sent out out roughly the same time as this one. Note that they are inter-
dependent, i.e., applying one without the other will not result in a
working build.
Patches #1 to #4 are cleanups. Patches #5 and #6 switch TC2 and FVP-AArch64
to the new and simplified DtPlatformDxe driver.
Ard Biesheuvel (6):
Platforms/VExpress: remove unused logo PCD
Platforms/VExpress: remove unused StatusCode references
Platforms/VExpress: get rid of Tiano compression
Platforms/VExpress: remove BdsLib library class resolutions
Platforms/TC2: move to new DtPlatformDxe driver
Platforms/FVP-AArch64: switch to simpler DT platform driver
Platforms/ARM/Binary/DeviceTree/fvp-base-gicv2-psci.dtb | Bin 0 -> 10368 bytes
Platforms/ARM/Binary/DeviceTree/fvp-base-gicv3-psci.dtb | Bin 0 -> 10835 bytes
Platforms/ARM/Binary/DeviceTree/fvp-foundation-gicv2-psci.dtb | Bin 0 -> 7673 bytes
Platforms/ARM/Binary/DeviceTree/fvp-foundation-gicv3-psci.dtb | Bin 0 -> 8140 bytes
Platforms/ARM/Binary/DeviceTree/vexpress-v2p-ca15_a7.dtb | Bin 0 -> 19070 bytes
Platforms/ARM/Juno/ArmJuno.dsc | 8 +++
Platforms/ARM/Juno/ArmJuno.fdf | 9 ----
Platforms/ARM/VExpress/ArmVExpress-CTA15-A7.dsc | 15 ++++--
Platforms/ARM/VExpress/ArmVExpress-CTA15-A7.fdf | 27 ++--------
Platforms/ARM/VExpress/ArmVExpress-FVP-AArch64.dsc | 31 +++++++-----
Platforms/ARM/VExpress/ArmVExpress-FVP-AArch64.fdf | 52 ++++----------------
Platforms/ARM/VExpress/ArmVExpress.dsc.inc | 24 +--------
12 files changed, 51 insertions(+), 115 deletions(-)
create mode 100644 Platforms/ARM/Binary/DeviceTree/fvp-base-gicv2-psci.dtb
create mode 100644 Platforms/ARM/Binary/DeviceTree/fvp-base-gicv3-psci.dtb
create mode 100644 Platforms/ARM/Binary/DeviceTree/fvp-foundation-gicv2-psci.dtb
create mode 100644 Platforms/ARM/Binary/DeviceTree/fvp-foundation-gicv3-psci.dtb
create mode 100644 Platforms/ARM/Binary/DeviceTree/vexpress-v2p-ca15_a7.dtb
--
2.9.3
Hi,
Quick resend of the RTC support - one file remained unstaged and had
to be added. I'm sorry for noise. All details can be found in the changelog
below.
The patches are also available in the github.
https://github.com/MarvellEmbeddedProcessors/edk2-open-platform/commits/opp…
Any comments or remarks would be very welcome.
Best regards,
Marcin
Changelog:
v2 -> v3:
* Add missing local header
* Slightly reword patch 2/2 commit log
v1 -> v2:
* Include <Library/UefiBootServicesTableLib.h> instead of extern *gBS
* Remove RtcReset function entirely
* Add RtcDelayedWrite helper function for modification of time and alarm
registers - cleaner code, with common valid comment.
* Use MmioAndThenOr32 instead of RtcUpdateMbusTimingParams function, remove
magic
* Add proper error path instead of assertions
* Move defines to local header
* Create new RTC description template in MvHwDescLib.h and use it for
obtaining controller data.
* Sort packages in inf file
Marcin Wojtas (2):
Platforms/Marvell: Introduce RTC support
Platforms/Marvell: Enable RTC library on Armada70x0 platforms
Platforms/Marvell/Armada/Armada.dsc.inc | 3 +-
Platforms/Marvell/Armada/Armada70x0.dsc | 3 +
.../Library/RealTimeClockLib/RealTimeClockLib.c | 335 +++++++++++++++++++++
.../Library/RealTimeClockLib/RealTimeClockLib.h | 50 +++
.../Library/RealTimeClockLib/RealTimeClockLib.inf | 53 ++++
Platforms/Marvell/Include/Library/MvHwDescLib.h | 25 ++
Platforms/Marvell/Marvell.dec | 3 +
7 files changed, 471 insertions(+), 1 deletion(-)
create mode 100644 Platforms/Marvell/Armada/Library/RealTimeClockLib/RealTimeClockLib.c
create mode 100644 Platforms/Marvell/Armada/Library/RealTimeClockLib/RealTimeClockLib.h
create mode 100644 Platforms/Marvell/Armada/Library/RealTimeClockLib/RealTimeClockLib.inf
--
1.8.3.1
Hi,
After introduction of MvHwDescLib got merged, I submit second version
of the RTC support, which now use it as well. Other than that all
remarks from v1 are answered, details can be found in the changelog below.
The patches are also available in the github.
https://github.com/MarvellEmbeddedProcessors/edk2-open-platform/commits/opp…
Any comments or remarks would be very welcome.
Best regards,
Marcin
Changelog:
v1 -> v2:
* Include <Library/UefiBootServicesTableLib.h> instead of extern *gBS
* Remove RtcReset function entirely
* Add RtcDelayedWrite helper function for modification of time and alarm
registers - cleaner code, with common valid comment.
* Use MmioAndThenOr32 instead of RtcUpdateMbusTimingParams function, remove
magic
* Add proper error path instead of assertions
* Move defines to local header
* Create new RTC description template in MvHwDescLib.h and use it for
obtaining controller data.
* Sort packages in inf file
Marcin Wojtas (2):
Platforms/Marvell: Introduce RTC support
Platforms/Marvell: Enable RTC library on Armada70x0 platforms
Platforms/Marvell/Armada/Armada.dsc.inc | 3 +-
Platforms/Marvell/Armada/Armada70x0.dsc | 3 +
.../Library/RealTimeClockLib/RealTimeClockLib.c | 335 +++++++++++++++++++++
.../Library/RealTimeClockLib/RealTimeClockLib.inf | 53 ++++
Platforms/Marvell/Include/Library/MvHwDescLib.h | 25 ++
Platforms/Marvell/Marvell.dec | 3 +
6 files changed, 421 insertions(+), 1 deletion(-)
create mode 100644 Platforms/Marvell/Armada/Library/RealTimeClockLib/RealTimeClockLib.c
create mode 100644 Platforms/Marvell/Armada/Library/RealTimeClockLib/RealTimeClockLib.inf
--
1.8.3.1
Hi,
Here's third version of the patchset comprising minor issues fixed pointed
in v2.
The commits are also available in the github:
https://github.com/MarvellEmbeddedProcessors/edk2-open-platform/commits/opp…
Any remarks or comments will be very welcome.
Best regards,
Marcin
Changelog
v2 -> v3:
* Add reviewed-by's to 1/4 and 3/4
* 1/4 Add 'Status = EFI_INVALID_PARAMETER' in switch default and remove
default variable initalization
* 3/4 For clarity leave NonDiscoverable header in PciEmulation as well
* 4/4 Fix whitespaces
v1 -> v2:
* 1/4: Change type of COMPHY_CHIP_INIT callback to VOID and rework Status usage
* 2/4: Add 'Reviewed-by'
* 3/4:
- Sort includes in header
- Rename 'storage' to 'nondiscoverable' in all macros and names
- Add defines for array sizes in definition
- Add defines for base addresses, so that they describe HW block and device
- Add comments for sections
* 4/4:
- Remove 'Ptr' suffixes
- Move and rename DEV_ENABLED macro from PciEmulation driver - use it in
ComPhy code
- Simplify obtaining enabled Sata ports and do not return EFI_SUCCESS on
PCD mismatch (lane enabled in ComPhy, despite the controller disabled)
- Add macros for controller ID's
- Remove unrelated style fixes
- Rewrite error print information in ComPhyCp110Init, because from now we
have more root causes than PLL
Konstantin Porotchkin (4):
Platforms/Marvell: ComPhyLib: Fix compilation warning
Platforms/Marvell: Add support for COMPHY on CP slaves
Platform/Marvell: Extend and share the platform description
Platform/Marvell: ComPhyLib: Enable SATA PHY init for multiple devices
Platforms/Marvell/Armada/Armada70x0.dsc | 9 +-
Platforms/Marvell/Include/Library/MvHwDescLib.h | 106 ++++++++++++++++++++++
Platforms/Marvell/Library/ComPhyLib/ComPhyCp110.c | 45 ++++++---
Platforms/Marvell/Library/ComPhyLib/ComPhyLib.c | 8 +-
Platforms/Marvell/Library/ComPhyLib/ComPhyLib.h | 4 +-
Platforms/Marvell/Library/ComPhyLib/ComPhyLib.inf | 3 +-
Platforms/Marvell/Marvell.dec | 3 -
Platforms/Marvell/PciEmulation/PciEmulation.c | 51 ++---------
8 files changed, 156 insertions(+), 73 deletions(-)
create mode 100644 Platforms/Marvell/Include/Library/MvHwDescLib.h
--
1.8.3.1
Hi,
I submit v2 of Armada 7k/8k improvements. It addresses all comments from
review and add some minor improvements. Details can be found in the
changelog and commit logs.
The commits are also available in the github:
https://github.com/MarvellEmbeddedProcessors/edk2-open-platform/commits/opp…
Any remarks or comments will be very welcome.
Best regards,
Marcin
Changelog
v1 -> v2:
* 1/4: Change type of COMPHY_CHIP_INIT callback to VOID and rework Status usage
* 2/4: Add 'Reviewed-by'
* 3/4:
- Sort includes in header
- Rename 'storage' to 'nondiscoverable' in all macros and names
- Add defines for array sizes in definition
- Add defines for base addresses, so that they describe HW block and device
- Add comments for sections
* 4/4:
- Remove 'Ptr' suffixes
- Move and rename DEV_ENABLED macro from PciEmulation driver - use it in
ComPhy code
- Simplify obtaining enabled Sata ports and do not return EFI_SUCCESS on
PCD mismatch (lane enabled in ComPhy, despite the controller disabled)
- Add macros for controller ID's
- Remove unrelated style fixes
- Rewrite error print information in ComPhyCp110Init, because from now we
have more root causes than PLL
Konstantin Porotchkin (4):
Platforms/Marvell: ComPhyLib: Fix compilation warning
Platforms/Marvell: Add support for COMPHY on CP slaves
Platform/Marvell: Extend and share the platform description
Platform/Marvell: ComPhyLib: Enable SATA PHY init for multiple devices
Platforms/Marvell/Armada/Armada70x0.dsc | 9 +-
Platforms/Marvell/Include/Library/MvHwDescLib.h | 106 ++++++++++++++++++++++
Platforms/Marvell/Library/ComPhyLib/ComPhyCp110.c | 46 ++++++----
Platforms/Marvell/Library/ComPhyLib/ComPhyLib.c | 8 +-
Platforms/Marvell/Library/ComPhyLib/ComPhyLib.h | 4 +-
Platforms/Marvell/Library/ComPhyLib/ComPhyLib.inf | 3 +-
Platforms/Marvell/Marvell.dec | 4 -
Platforms/Marvell/PciEmulation/PciEmulation.c | 52 ++---------
8 files changed, 156 insertions(+), 76 deletions(-)
create mode 100644 Platforms/Marvell/Include/Library/MvHwDescLib.h
--
1.8.3.1