On Sat, 15 Oct 2011 01:29:33 +0200, Andrew Morton akpm@linux-foundation.org wrote:
On Thu, 06 Oct 2011 15:54:42 +0200 Marek Szyprowski m.szyprowski@samsung.com wrote:
From: KAMEZAWA Hiroyuki kamezawa.hiroyu@jp.fujitsu.com
This commit introduces alloc_contig_freed_pages() function
The "freed" seems redundant to me. Wouldn't "alloc_contig_pages" be a better name?
The “freed” is there because the function operates on pages that are in buddy system, ie. it is given a range of PFNs that are to be removed from buddy system.
There's also a alloc_contig_range() function (added by next patch) which frees pages in given range and then calls alloc_contig_free_pages() to allocate them.
IMO, if there was an alloc_contig_pages() function, it would have to be one level up (ie. it would figure out where to allocate memory and then call alloc_contig_range()). (That's really what CMA is doing).
Still, as I think of it now, maybe alloc_contig_free_range() would be better?