On 11/28/22 11:53, Maxime Ripard wrote:
Commit 44a3928324e9 ("drm/tests: Add Kunit Helpers") introduced the drm_kunit_device_init() function but didn't document it properly. Add that documentation.
Signed-off-by: Maxime Ripard maxime@cerno.tech
Just a minor nit on naming, besides that:
Reviewed-by: Maíra Canal mcanal@igalia.com
drivers/gpu/drm/tests/drm_kunit_helpers.c | 17 +++++++++++++++++ 1 file changed, 17 insertions(+)
diff --git a/drivers/gpu/drm/tests/drm_kunit_helpers.c b/drivers/gpu/drm/tests/drm_kunit_helpers.c index 6600a4db3158..46a68c2fd80c 100644 --- a/drivers/gpu/drm/tests/drm_kunit_helpers.c +++ b/drivers/gpu/drm/tests/drm_kunit_helpers.c @@ -35,6 +35,23 @@ static void dev_free(struct kunit_resource *res) root_device_unregister(dev); } +/**
- drm_kunit_device_init - Allocates a mock DRM device for Kunit tests
s/Kunit/KUnit
Best Regards, - Maíra Canal
- @test: The test context object
- @features: Mocked DRM device driver features
- @name: Name of the struct &device to allocate
- This function allocates a new struct &device, creates a struct
- &drm_driver and will create a struct &drm_device using both.
- The device and driver are tied to the @test context and will get
- cleaned at the end of the test. The drm_device is allocated through
- devm_drm_dev_alloc() and will thus be freed through a device-managed
- resource.
- Returns:
- A pointer to the new drm_device, or an ERR_PTR() otherwise.
- */
struct drm_device *drm_kunit_device_init(struct kunit *test, u32 features, char *name) { struct kunit_dev *kdev;