On Wed, Jul 29, 2026 at 11:37:19AM +0100, Pavel Begunkov wrote:
On 7/29/26 07:59, Christoph Hellwig wrote:
The method name feels a bit convoluted, but given all the previous discussions I don't care too strongly. I'll leave the dma-buf side review to those who understand it.
I assume you mean this:
Yes.
- int (*init_dma_buf_io_ctx)(struct file *, struct dma_buf_io_ctx *);
I agree, and all dma_buf_io_[ctx,map] look clunky, but I don't see what I can drop out of the name. Suggestions? Maybe I at least should make the fs op sth like "register_dma_buf".
I just remember scares from the last discussion :)
register_dma_buf sounds fine to be, but unless I misremember there were objections to that before.
-- Pavel Begunkov
---end quoted text---