My previous patchset[1] had too many types of patches (cleanups,
bug fixes, additions, etc.), so it will be broken up much further
to make it easy on the eyes :)
This particular set focuses on renaming existing sanity scripts,
adding a new one to the cputopology test module, and if the
changes look good, then update the Android makefiles to include
the new test names. The PM-QA wiki[2] will be updated as well.
[1] http://lists.linaro.org/pipermail/linaro-dev/2015-February/017797.html
[2] https://wiki.linaro.org/WorkingGroups/PowerManagement/
Resources/TestSuite/PmQaSpecification
Lisa Nguyen (4):
cpuhotplug: Rename 1_sanity_check files to cpuhotplug_00 files
cpuhotplug: Rename z_sanity_check files to cpuhotplug_99 files
cputopology: Add cputopology_sanity.sh
Android: Update makefiles with new test numbers
cpuhotplug/1_sanity_check.sh | 40 -----------------------------
cpuhotplug/1_sanity_check.txt | 1 -
cpuhotplug/Android.mk | 4 +--
cpuhotplug/cpuhotplug_00.sh | 40 +++++++++++++++++++++++++++++
cpuhotplug/cpuhotplug_00.txt | 1 +
cpuhotplug/cpuhotplug_99.sh | 40 +++++++++++++++++++++++++++++
cpuhotplug/cpuhotplug_99.txt | 1 +
cpuhotplug/z_sanity_check.sh | 40 -----------------------------
cpuhotplug/z_sanity_check.txt | 1 -
cputopology/Android.mk | 2 +-
cputopology/cputopology_sanity.sh | 49 ++++++++++++++++++++++++++++++++++++
cputopology/cputopology_sanity.txt | 1 +
12 files changed, 134 insertions(+), 86 deletions(-)
delete mode 100755 cpuhotplug/1_sanity_check.sh
delete mode 100644 cpuhotplug/1_sanity_check.txt
create mode 100755 cpuhotplug/cpuhotplug_00.sh
create mode 100644 cpuhotplug/cpuhotplug_00.txt
create mode 100755 cpuhotplug/cpuhotplug_99.sh
create mode 100644 cpuhotplug/cpuhotplug_99.txt
delete mode 100755 cpuhotplug/z_sanity_check.sh
delete mode 100644 cpuhotplug/z_sanity_check.txt
create mode 100755 cputopology/cputopology_sanity.sh
create mode 100644 cputopology/cputopology_sanity.txt
--
1.7.9.5
Changes in v2:
- Reorganized previous patchset and recreated patches based on
logical change
- Rewritten logic to find certain attributes in sysfs
[Let's try again...]
This patchset primarily fixes Linaro Bug# 772
(https://bugs.linaro.org/show_bug.cgi?id=772) to remove
bashisms in all PM-QA scripts. These scripts will run on
Android, Openembedded, and Ubuntu.
Cleanups have been done to remove redundant code, improve
readability, and resolve syntax errors that were not
detected before.
Currently, the suspend and powertop test modules are disabled.
However, to maintain consistency, the format of the suspend
and powertop scripts have been updated to be POSIX-compliant.
Next steps:
Once this patchset has been reviewed and acked, the following
steps will be taken:
1. Submit a patch to update the release tag on the pwrmgmt
test definitions to pm-qa-v0.5.0
2. Submit a patch to update the pm-qa script
(https://git.linaro.org/qa/test-definitions.git/blob/HEAD:/common/scripts/pm…)
used to run PM-QA on Android by removing unnecessary busybox sym
links and replace suspend test module with thermal in
directory list.
3. Investigate further on why pandaboards do not like the
cpuidle_03 test case.
4. Update the PM-QA wiki with new test cases and their descriptions:
https://wiki.linaro.org/WorkingGroups/PowerManagement/Resources/TestSuite/P…
Comments and/or questions are highly encouraged.
Lisa Nguyen (25):
Fix path to library files and change shebang line
Replace double equals with one for comparison
Remove sigtrap prefixes for traps
Remove local keywords and uninitialized variables
Fix syntax to get the cpu id number
Remove thermal_try_max variable
Switches: Add hotplug_allow_cpu0=0
cpuhotplug: Rewrite randomize() function
Fix the syntax to call C programs
cpuidle: Use is_root() function in cpuidle_03
Remove unused variables and rename some
Remove BASH arrays
Rewrite logic to check for sampling_rate
suspend_functions: Check if $LOGDIR exists
cpuhotplug: Rename 1_sanity_check files to cpuhotplug_00 files
cpuhotplug: Rename z_sanity_check files to cpuhotplug_99
cputopology: Add cputopology_sanity.sh
Android: Update makefiles with new test numbers
Use -q option for grep command
Improve test conditions to see if a directory or file exists
cpufreq: Remove unnecessary checks
Test: Add sort function
cpufreq: Check to see if scaling_available_governors is available
cpufreq: Rewrite logic to check if powersave is supported
Whitespace cleanup
Switches.sh | 6 +-
Test.mk | 2 +-
cpufreq/cpufreq_01.sh | 4 +-
cpufreq/cpufreq_02.sh | 4 +-
cpufreq/cpufreq_03.sh | 15 +-
cpufreq/cpufreq_04.sh | 16 +--
cpufreq/cpufreq_05.sh | 105 +++++++-------
cpufreq/cpufreq_06.sh | 46 +++---
cpufreq/cpufreq_07.sh | 47 +++----
cpufreq/cpufreq_08.sh | 26 ++--
cpufreq/cpufreq_09.sh | 28 ++--
cpufreq/cpufreq_sanity.sh | 10 +-
cpuhotplug/1_sanity_check.sh | 40 ------
cpuhotplug/1_sanity_check.txt | 1 -
cpuhotplug/Android.mk | 4 +-
cpuhotplug/cpuhotplug_00.sh | 40 ++++++
cpuhotplug/cpuhotplug_00.txt | 1 +
cpuhotplug/cpuhotplug_01.sh | 5 +-
cpuhotplug/cpuhotplug_02.sh | 23 ++-
cpuhotplug/cpuhotplug_03.sh | 18 ++-
cpuhotplug/cpuhotplug_04.sh | 17 +--
cpuhotplug/cpuhotplug_05.sh | 13 +-
cpuhotplug/cpuhotplug_06.sh | 15 +-
cpuhotplug/cpuhotplug_07.sh | 26 ++--
cpuhotplug/cpuhotplug_08.sh | 22 +--
cpuhotplug/cpuhotplug_99.sh | 40 ++++++
cpuhotplug/cpuhotplug_99.txt | 1 +
cpuhotplug/cpuhotplug_sanity.sh | 6 +-
cpuhotplug/z_sanity_check.sh | 40 ------
cpuhotplug/z_sanity_check.txt | 1 -
cpuidle/cpuidle_01.sh | 18 ++-
cpuidle/cpuidle_02.sh | 6 +-
cpuidle/cpuidle_03.sh | 16 +--
cpuidle/cpuidle_sanity.sh | 7 +-
cputopology/Android.mk | 2 +-
cputopology/cputopology_01.sh | 9 +-
cputopology/cputopology_02.sh | 4 +-
cputopology/cputopology_sanity.sh | 49 +++++++
cputopology/cputopology_sanity.txt | 1 +
include/functions.sh | 274 +++++++++++++++++-------------------
include/suspend_functions.sh | 21 +--
include/thermal_functions.sh | 215 ++++++++++++++--------------
powertop/powertop_01.sh | 19 ++-
powertop/powertop_sanity.sh | 7 +-
suspend/suspend_01.sh | 6 +-
suspend/suspend_02.sh | 8 +-
suspend/suspend_03.sh | 6 +-
suspend/suspend_04.sh | 6 +-
suspend/suspend_05.sh | 14 +-
suspend/suspend_sanity.sh | 4 +-
thermal/thermal_00.sh | 22 +--
thermal/thermal_01.sh | 43 +++---
thermal/thermal_02.sh | 42 +++---
thermal/thermal_03.sh | 18 +--
thermal/thermal_04.sh | 59 ++++----
thermal/thermal_05.sh | 50 +++----
thermal/thermal_06.sh | 96 +++++++------
thermal/thermal_sanity.sh | 7 +-
utils/utils_sanity.sh | 4 +-
59 files changed, 827 insertions(+), 828 deletions(-)
delete mode 100755 cpuhotplug/1_sanity_check.sh
delete mode 100644 cpuhotplug/1_sanity_check.txt
create mode 100755 cpuhotplug/cpuhotplug_00.sh
create mode 100644 cpuhotplug/cpuhotplug_00.txt
create mode 100755 cpuhotplug/cpuhotplug_99.sh
create mode 100644 cpuhotplug/cpuhotplug_99.txt
delete mode 100755 cpuhotplug/z_sanity_check.sh
delete mode 100644 cpuhotplug/z_sanity_check.txt
create mode 100755 cputopology/cputopology_sanity.sh
create mode 100644 cputopology/cputopology_sanity.txt
--
1.7.9.5
****************
Team Work Logged
****************
# tyler-baker Progress #
* LAVA-1511 - Upstream Kernel CI
* LAVA-1830 - Implement file upload API in lava-ci (80.0%)
* Had a quick discussion with Milo, who pointed out the example was incorrect. After fixing up the code, the single file upload is working and pushed in the lava-ci project. I'm currently testing it using my trigger. The plan here is that if there are no issues detected in the next few days, move the builders to use a the file upload api for publishing.
* LAVA-1511 - Upstream Kernel CI
* LAVA-1829 - Improve Kernel-CI E-mail Reporting (20.0%)
* Milo has reviewed this change and I've pushed an updated patch set to reflect his comments. There is some cleanup work to be done, along with adding the unique boots/boards/builds that kevin h. has requested.
# stylesen Progress #
* LAVA-1317 - lava-dispatcher maintenance
* LAVA-1414 - LC: Linaro login integration with LAVA (85.71%)
* working on the extension patch.
* LAVA-1608 - General Team Items
* LAVA-1609 - Senthil's Bugs (14.29%)
* Initial analysis on the bug.
* Found the root cause and provided a fix in the test definition to the QA team.
# remi.duraffort(a)st.com Progress #
* LAVA-1608 - General Team Items
* LAVA-1611 - Remi's Bugs (50.0%)
* Look at Pipeline auto description function to dump a simple representation of the pipeline.
* Finish the Pipeline dump. Use the dump to compare Pipeline built in the test against a reference dump.
* LAVA-1429 - Dispatcher Refactoring
* LAVA-1784 - New device configuration (50.0%)
* Factorize code
Fix some unitt tests
* Patches delivered.
Still some work to unify the configuration format and to write down the configuration generator.
# gesha Progress #
* LAVA-1317 - lava-dispatcher maintenance
* LAVA-1381 - LC: Simple Loops within LAVA jobs (100.0%)
* Added repeat iteration to the dashboard.
# neil.williams(a)linaro.org Progress #
* LAVA-1429 - Dispatcher Refactoring
* LAVA-1804 - DF: Implement advanced use cases (100.0%)
# milo Progress #
* LAVA-1511 - Upstream Kernel CI
* LAVA-1811 - Frontend UI improvements/requests (68.57%)
* Fixed spacing issues on boots table.
* Started work on boot bisect data for a tree compared to mainline
* Worked on the backed and frontend code, tested locally.
* Continued working on bisect comparison: added logic for bisect script.
* Implemented defconfig/build bisection compared to mainline.
* Fixed wording on FAQ page.
* LAVA-1511 - Upstream Kernel CI
* LAVA-1554 - [backend] Email notification system (22.86%)
* Looked into problem with multiple emails sent.
* Deployed changes in production and tested that emails still work.
* Took a look at why just one tree email was sent multiple times.
* LAVA-1608 - General Team Items
* LAVA-1836 - Milo's Code Review (8.57%)
* Reviewed and tested Tyler's changes for kernelci email reporting.
* Reviewed second patch, tested and merged.
****************
Team In-Progress
****************
# georgy.redkozubov(a)linaro.org Plan #
* LAVA-1776 - Create lava-test-shell helpers for background process handling
# milo.casagrande(a)linaro.org Plan #
* LAVA-1840 - Fix FAQ page wording
* LAVA-1651 - Health monitoring for components
* LAVA-1837 - Review #4410
* LAVA-1554 - [backend] Email notification system
* LAVA-1835 - Display boot bisect data compared to mainline
# neil.williams(a)linaro.org Plan #
* LAVA-1806 - Port VMGroup support as secondary connections
* LAVA-1827 - Extend Multinode for delayed start
# remi.duraffort(a)linaro.org Plan #
* LAVA-1680 - Factorize utils functions in a specific module
* LAVA-1580 - Download Helper
* LAVA-1577 - VCS Helper class
* LAVA-1784 - New device configuration
* LAVA-1755 - ST boards support
# senthil.kumaran(a)linaro.org Plan #
* LAVA-1823 - Provide support for Asian Languages (enable user fields)
* LAVA-1414 - LC: Linaro login integration with LAVA
* LAVA-1832 - LAVA Extension for Linaro Login Service
# stevan.radakovic(a)linaro.org Plan #
* LAVA-1629 - 808
* LAVA-1598 - 330
* LAVA-1813 - LSK image reports migration
# tyler.baker(a)linaro.org Plan #
* LAVA-1792 - Tyler's Mentoring
* LAVA-1785 - Investigate and Integrate member development board
* LAVA-1819 - Draft Blog Post for Upstream Kernel CI Project
* LAVA-1818 - Document Upstream Kernel CI Project on WIKI
* LAVA-1829 - Improve Kernel-CI E-mail Reporting
* LAVA-1830 - Implement file upload API in lava-ci