This patch allows to decouple and recouple the gic from the PRCMU. This is needed to put the A9 core in retention mode with the cpuidle driver.
Signed-off-by: Daniel Lezcano daniel.lezcano@linaro.org --- drivers/mfd/db8500-prcmu.c | 29 +++++++++++++++++++++++++++++ include/linux/mfd/db8500-prcmu.h | 2 ++ include/linux/mfd/dbx500-prcmu.h | 16 ++++++++++++++++ 3 files changed, 47 insertions(+), 0 deletions(-)
diff --git a/drivers/mfd/db8500-prcmu.c b/drivers/mfd/db8500-prcmu.c index af8e0ef..70f39a1 100644 --- a/drivers/mfd/db8500-prcmu.c +++ b/drivers/mfd/db8500-prcmu.c @@ -787,6 +787,35 @@ int db8500_prcmu_set_power_state(u8 state, bool keep_ulp_clk, bool keep_ap_pll) return 0; }
+#define PRCMU_A9_MASK_REQ 0x00000328 +#define PRCMU_A9_MASK_REQ_MASK 0x00000001 +#define PRCMU_GIC_DELAY 1 + +/* This function decouple the gic from the prcmu */ +void db8500_prcmu_gic_decouple(void) +{ + u32 val = readl(_PRCMU_BASE + PRCMU_A9_MASK_REQ); + + /* Set bit 0 register value to 1 */ + writel((val & ~PRCMU_A9_MASK_REQ_MASK) | PRCMU_A9_MASK_REQ_MASK, + _PRCMU_BASE + PRCMU_A9_MASK_REQ); + + /* Make sure the register is updated */ + readl(_PRCMU_BASE + PRCMU_A9_MASK_REQ); + + /* Wait a few cycles for the gic mask completion */ + udelay(PRCMU_GIC_DELAY); +} + +/* This function recouple the gic with the prcmu */ +void db8500_prcmu_gic_recouple(void) +{ + u32 val = readl(_PRCMU_BASE + PRCMU_A9_MASK_REQ); + + /* Set bit 0 register value to 0 */ + writel((val & ~PRCMU_A9_MASK_REQ_MASK), _PRCMU_BASE + PRCMU_A9_MASK_REQ); +} + /* This function should only be called while mb0_transfer.lock is held. */ static void config_wakeups(void) { diff --git a/include/linux/mfd/db8500-prcmu.h b/include/linux/mfd/db8500-prcmu.h index 60d27f7..4a1032c 100644 --- a/include/linux/mfd/db8500-prcmu.h +++ b/include/linux/mfd/db8500-prcmu.h @@ -536,6 +536,8 @@ int prcmu_load_a9wdog(u8 id, u32 val);
void db8500_prcmu_system_reset(u16 reset_code); int db8500_prcmu_set_power_state(u8 state, bool keep_ulp_clk, bool keep_ap_pll); +void db8500_prcmu_gic_disable(void); +void db8500_prcmu_gic_enable(void); void db8500_prcmu_enable_wakeups(u32 wakeups); int db8500_prcmu_set_epod(u16 epod_id, u8 epod_state); int db8500_prcmu_request_clock(u8 clock, bool enable); diff --git a/include/linux/mfd/dbx500-prcmu.h b/include/linux/mfd/dbx500-prcmu.h index bac942f..a5fee69 100644 --- a/include/linux/mfd/dbx500-prcmu.h +++ b/include/linux/mfd/dbx500-prcmu.h @@ -237,6 +237,22 @@ static inline int prcmu_set_power_state(u8 state, bool keep_ulp_clk, keep_ap_pll); }
+static inline void prcmu_gic_disable(void) +{ + if (machine_is_u5500()) + return; + else + return db8500_prcmu_gic_disable(); +} + +static inline void prcmu_gic_enable(void) +{ + if (machine_is_u5500()) + return; + else + return db8500_prcmu_gic_enable(); +} + static inline int prcmu_set_epod(u16 epod_id, u8 epod_state) { if (machine_is_u5500())
Hi Daniel!
Please see my embedded comments.
Also should we not keep the functions in pm.c file? I think Linus W advised us not to move stuff around at this stage.
BR Rickard
This patch allows to decouple and recouple the gic from the PRCMU. This is needed to put the A9 core in retention mode with the cpuidle driver.
Signed-off-by: Daniel Lezcanodaniel.lezcano@linaro.org
drivers/mfd/db8500-prcmu.c | 29 +++++++++++++++++++++++++++++ include/linux/mfd/db8500-prcmu.h | 2 ++ include/linux/mfd/dbx500-prcmu.h | 16 ++++++++++++++++ 3 files changed, 47 insertions(+), 0 deletions(-)
diff --git a/drivers/mfd/db8500-prcmu.c b/drivers/mfd/db8500-prcmu.c index af8e0ef..70f39a1 100644 --- a/drivers/mfd/db8500-prcmu.c +++ b/drivers/mfd/db8500-prcmu.c @@ -787,6 +787,35 @@ int db8500_prcmu_set_power_state(u8 state, bool keep_ulp_clk, bool keep_ap_pll) return 0; }
+#define PRCMU_A9_MASK_REQ 0x00000328 +#define PRCMU_A9_MASK_REQ_MASK 0x00000001 +#define PRCMU_GIC_DELAY 1
+/* This function decouple the gic from the prcmu */ +void db8500_prcmu_gic_decouple(void) +{
- u32 val = readl(_PRCMU_BASE + PRCMU_A9_MASK_REQ);
- /* Set bit 0 register value to 1 */
- writel((val& ~PRCMU_A9_MASK_REQ_MASK) | PRCMU_A9_MASK_REQ_MASK,
_PRCMU_BASE + PRCMU_A9_MASK_REQ);
No need to AND with ~PRCMU_A9_MASK_REQ_MASK. This is enough:
writel((val | PRCMU_A9_MASK_REQ_MASK, _PRCMU_BASE + PRCMU_A9_MASK_REQ);
- /* Make sure the register is updated */
- readl(_PRCMU_BASE + PRCMU_A9_MASK_REQ);
- /* Wait a few cycles for the gic mask completion */
- udelay(PRCMU_GIC_DELAY);
+}
+/* This function recouple the gic with the prcmu */ +void db8500_prcmu_gic_recouple(void) +{
- u32 val = readl(_PRCMU_BASE + PRCMU_A9_MASK_REQ);
- /* Set bit 0 register value to 0 */
- writel((val& ~PRCMU_A9_MASK_REQ_MASK), _PRCMU_BASE + PRCMU_A9_MASK_REQ);
+}
- /* This function should only be called while mb0_transfer.lock is held. */ static void config_wakeups(void) {
diff --git a/include/linux/mfd/db8500-prcmu.h b/include/linux/mfd/db8500-prcmu.h index 60d27f7..4a1032c 100644 --- a/include/linux/mfd/db8500-prcmu.h +++ b/include/linux/mfd/db8500-prcmu.h @@ -536,6 +536,8 @@ int prcmu_load_a9wdog(u8 id, u32 val);
void db8500_prcmu_system_reset(u16 reset_code); int db8500_prcmu_set_power_state(u8 state, bool keep_ulp_clk, bool keep_ap_pll); +void db8500_prcmu_gic_disable(void); +void db8500_prcmu_gic_enable(void); void db8500_prcmu_enable_wakeups(u32 wakeups); int db8500_prcmu_set_epod(u16 epod_id, u8 epod_state); int db8500_prcmu_request_clock(u8 clock, bool enable); diff --git a/include/linux/mfd/dbx500-prcmu.h b/include/linux/mfd/dbx500-prcmu.h index bac942f..a5fee69 100644 --- a/include/linux/mfd/dbx500-prcmu.h +++ b/include/linux/mfd/dbx500-prcmu.h @@ -237,6 +237,22 @@ static inline int prcmu_set_power_state(u8 state, bool keep_ulp_clk, keep_ap_pll); }
+static inline void prcmu_gic_disable(void) +{
- if (machine_is_u5500())
return;
- else
return db8500_prcmu_gic_disable();
+}
We have change name of this function in the .c file
+static inline void prcmu_gic_enable(void) +{
- if (machine_is_u5500())
return;
- else
return db8500_prcmu_gic_enable();
+}
We have change name of this function in the .c file
- static inline int prcmu_set_epod(u16 epod_id, u8 epod_state) { if (machine_is_u5500())
On 02/09/2012 11:52 AM, Rickard Andersson wrote:
Hi Daniel!
Please see my embedded comments.
Also should we not keep the functions in pm.c file? I think Linus W advised us not to move stuff around at this stage.
The pm.c file does not exists for mach-ux500. May be I misunderstood Linus but I thought he was saying to that we should "not move stuff around" by letting this code in the db8500-prcmu.c file for the moment and let Mattias do its cleanups.
BR Rickard
This patch allows to decouple and recouple the gic from the PRCMU. This is needed to put the A9 core in retention mode with the cpuidle driver.
Signed-off-by: Daniel Lezcanodaniel.lezcano@linaro.org
drivers/mfd/db8500-prcmu.c | 29 +++++++++++++++++++++++++++++ include/linux/mfd/db8500-prcmu.h | 2 ++ include/linux/mfd/dbx500-prcmu.h | 16 ++++++++++++++++ 3 files changed, 47 insertions(+), 0 deletions(-)
diff --git a/drivers/mfd/db8500-prcmu.c b/drivers/mfd/db8500-prcmu.c index af8e0ef..70f39a1 100644 --- a/drivers/mfd/db8500-prcmu.c +++ b/drivers/mfd/db8500-prcmu.c @@ -787,6 +787,35 @@ int db8500_prcmu_set_power_state(u8 state, bool keep_ulp_clk, bool keep_ap_pll) return 0; }
+#define PRCMU_A9_MASK_REQ 0x00000328 +#define PRCMU_A9_MASK_REQ_MASK 0x00000001 +#define PRCMU_GIC_DELAY 1
+/* This function decouple the gic from the prcmu */ +void db8500_prcmu_gic_decouple(void) +{
- u32 val = readl(_PRCMU_BASE + PRCMU_A9_MASK_REQ);
- /* Set bit 0 register value to 1 */
- writel((val& ~PRCMU_A9_MASK_REQ_MASK) | PRCMU_A9_MASK_REQ_MASK,
- _PRCMU_BASE + PRCMU_A9_MASK_REQ);
No need to AND with ~PRCMU_A9_MASK_REQ_MASK. This is enough:
writel((val | PRCMU_A9_MASK_REQ_MASK, _PRCMU_BASE + PRCMU_A9_MASK_REQ);
Yep, right.
[ cut ]
+static inline void prcmu_gic_disable(void) +{
- if (machine_is_u5500())
- return;
- else
- return db8500_prcmu_gic_disable();
+}
We have change name of this function in the .c file
+static inline void prcmu_gic_enable(void) +{
- if (machine_is_u5500())
- return;
- else
- return db8500_prcmu_gic_enable();
+}
We have change name of this function in the .c file
Do you want that in db8500-prcmu.c and declare the function in db8500-prcmu.h or dbx500-prcmu.h ?
On 02/09/2012 12:25 PM, Daniel Lezcano wrote:
On 02/09/2012 11:52 AM, Rickard Andersson wrote:
Hi Daniel!
Please see my embedded comments.
Also should we not keep the functions in pm.c file? I think Linus W advised us not to move stuff around at this stage.
The pm.c file does not exists for mach-ux500. May be I misunderstood Linus but I thought he was saying to that we should "not move stuff around" by letting this code in the db8500-prcmu.c file for the moment and let Mattias do its cleanups.
On our internal tree we have mach-ux500/pm/pm.c and this file contains the decouple-gic functions as well as other power management related help functions. By moving the code to drivers/mfd/db8500-prcmu.c I think we are moving code around. Especially since it not clear how db8500-prcmu.c will be handled in the future, db8500-prcmu.c should most likely be split into several parts where one part only handles the communication with the PRCMU firmware.
BR Rickard
This patch allows to decouple and recouple the gic from the PRCMU. This is needed to put the A9 core in retention mode with the cpuidle driver.
Signed-off-by: Daniel Lezcanodaniel.lezcano@linaro.org
drivers/mfd/db8500-prcmu.c | 29 +++++++++++++++++++++++++++++ include/linux/mfd/db8500-prcmu.h | 2 ++ include/linux/mfd/dbx500-prcmu.h | 16 ++++++++++++++++ 3 files changed, 47 insertions(+), 0 deletions(-)
diff --git a/drivers/mfd/db8500-prcmu.c b/drivers/mfd/db8500-prcmu.c index af8e0ef..70f39a1 100644 --- a/drivers/mfd/db8500-prcmu.c +++ b/drivers/mfd/db8500-prcmu.c @@ -787,6 +787,35 @@ int db8500_prcmu_set_power_state(u8 state, bool keep_ulp_clk, bool keep_ap_pll) return 0; }
+#define PRCMU_A9_MASK_REQ 0x00000328 +#define PRCMU_A9_MASK_REQ_MASK 0x00000001 +#define PRCMU_GIC_DELAY 1
+/* This function decouple the gic from the prcmu */ +void db8500_prcmu_gic_decouple(void) +{
- u32 val = readl(_PRCMU_BASE + PRCMU_A9_MASK_REQ);
- /* Set bit 0 register value to 1 */
- writel((val& ~PRCMU_A9_MASK_REQ_MASK) | PRCMU_A9_MASK_REQ_MASK,
- _PRCMU_BASE + PRCMU_A9_MASK_REQ);
No need to AND with ~PRCMU_A9_MASK_REQ_MASK. This is enough:
writel((val | PRCMU_A9_MASK_REQ_MASK, _PRCMU_BASE + PRCMU_A9_MASK_REQ);
Yep, right.
[ cut ]
+static inline void prcmu_gic_disable(void) +{
- if (machine_is_u5500())
- return;
- else
- return db8500_prcmu_gic_disable();
+}
We have change name of this function in the .c file
+static inline void prcmu_gic_enable(void) +{
- if (machine_is_u5500())
- return;
- else
- return db8500_prcmu_gic_enable();
+}
We have change name of this function in the .c file
Do you want that in db8500-prcmu.c and declare the function in db8500-prcmu.h or dbx500-prcmu.h ?
On 02/09/2012 01:19 PM, Rickard Andersson wrote:
On 02/09/2012 12:25 PM, Daniel Lezcano wrote:
On 02/09/2012 11:52 AM, Rickard Andersson wrote:
Hi Daniel!
Please see my embedded comments.
Also should we not keep the functions in pm.c file? I think Linus W advised us not to move stuff around at this stage.
The pm.c file does not exists for mach-ux500. May be I misunderstood Linus but I thought he was saying to that we should "not move stuff around" by letting this code in the db8500-prcmu.c file for the moment and let Mattias do its cleanups.
On our internal tree we have mach-ux500/pm/pm.c and this file contains the decouple-gic functions as well as other power management related help functions. By moving the code to drivers/mfd/db8500-prcmu.c I think we are moving code around. Especially since it not clear how db8500-prcmu.c will be handled in the future, db8500-prcmu.c should most likely be split into several parts where one part only handles the communication with the PRCMU firmware.
Rickard,
the reference is the mainstream code. Today there is no pm.c file and everything is located in db8500-prcmu.c. Except if I misunderstood, if Linus, who is the maintainer of the ux500 SoC, prefers to have this portion of code in this file until Mattias does its cleanups, that does not really matter if it is in pm.c or db8500-prcmu.c for the moment.
That does not mean this code won't be moved to pm.c in the future.
Thanks -- Daniel
(I took this discussion off linux-arm-kernel because I think the majority on that list doesn't really care about this stuff.)
On Thu, Feb 9, 2012 at 1:19 PM, Rickard Andersson rickard.andersson@stericsson.com wrote:
it not clear how db8500-prcmu.c will be handled in the future, db8500-prcmu.c should most likely be split into several parts where one part only handles the communication with the PRCMU firmware.
Yes, I can answer so much: I am to author a letter to Greg (the device driver architecture maintainer) about "system controllers" and where to really put them.
There are maybe three pieces to the PRCMU: (1) PRCMU registers (MFD) (2) PRCMU firmware (MFD?) (3) System control (new subsystem? back to arch/arm/*?)
And then there are all subdrivers using it, like cpuidle, cpufreq, watchdog, hwmon and maybe a few more, which would use .h files for any/some of the above.
So it really needs a good structure and AFAIK Mattias is working on this.
As for merging this one patch I have one question mainly, and that is whether it was done on top of the patches I have pending to bring the mainline PRCMU code upto (one) date and that have already been submitted? (8 patches, cover letter says "DB8500 PRCMU update")
That set brings the current code up to where "internal development" i.e. http://www.igloocommunity.org/gitweb/?p=kernel/igloo-kernel.git%3Ba=shortlog... was at one point. (Now it's already progressed a bit I think...)
If we agree on the function signatures it doesn't matter much where they end up right now if you absolutely need it to go in, it will cause some churn but we can always move them about later, but the semantics for them are really crucial. (In the end it's not me but Samuel Ortiz who merges MFD patches BTW.)
Yours, Linus Walleij